Reply
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Feedback on the new Upwork Team App

Highlighted
Active Member
Hristina D Member Since: Jun 22, 2015
131 of 155
Hello, Ivo,

Hristina from Bulgaria here. I have a question:

Is the Upwork Team App compatible with Windows 8.1?
Highlighted
Moderator
Valeria K Moderator Member Since: Mar 6, 2014
132 of 155

Hi Hristina,

 

Yes, Upwork Team App works best on Windows 7 and above.

~ Valeria
Untitled
Highlighted
Community Guru
Natacha R Member Since: Aug 2, 2010
133 of 155

Is it normal not to see anyone, not even client? I used to be able to see everyone, not that I miss this, on one of my contracts it’s a huge team and some used to ping me, which was really annoying as sometimes I would be online but working for another client.

Highlighted
Community Guru
Olga Q Member Since: Sep 5, 2012
134 of 155

@Natasha R wrote:

Is it normal not to see anyone, not even client? I used to be able to see everyone, not that I miss this, on one of my contracts it’s a huge team and some used to ping me, which was really annoying as sometimes I would be online but working for another client.


 It's normal. I've been using the new app for quite some time and that feature was never available, so I guess they've abandoned it. A good idea, in my humble opinion.

Highlighted
Active Member
Theodore Albert L Member Since: May 13, 2008
135 of 155

I've noticed that whenever an update gets pushed and the app is restarted that I lose all my all settings and have to put them all back. What's most annoying is that I have to type in the work memos as I go along since the list is wiped clean. Ideally, any update should retain the previous settings and data.

Highlighted
Moderator
Vladimir G Moderator Member Since: Oct 31, 2014
136 of 155

Hi Theodore,

 

I've shared your concerns with Ivo and the team, and can confirm we're looking into this.

 

Thanks for the feedback.

Highlighted
Active Member
Han C Member Since: Feb 19, 2015
137 of 155
It's been online for months and no shortcut to start time tracking? How come.
Highlighted
Active Member
Diki A Member Since: Feb 27, 2016
138 of 155

Hi, upwork developer

 

Please update the software. I have issues on libnss and relation with ssl on linux.

Says Error Message: THERE WAS A PROBLEM LOADING UPWORK

 

I downgrade package libnss, its work, but in browser has critical if I use https mode. And I upgrading again to solved https mode in my browser.

 

 

Visit Link Post.

 

Hopefully you update it.

 

Diki.

Highlighted
Active Member
Guney O Member Since: Jan 21, 2016
139 of 155

Hi Ivo,

 

I'm quite late to the discussion but I've just discovered that Team App shortcuts was the reason behind some typing and shortcut problems on my other software like Visual Studio, Open Broadcast Software, Cubase...etc. Introducing such changes without an opt-in system is very dangerous. I even tracked time to some client without even noticing.

I discovered the solution by chance when I started the time tracker for an unrelevant job while I was working in Visual Studio.

 

I think similar updates should give appropriate notice and be opt-in, or at least a pop-up should make everyone set those to prevent breaking other apps.

Guney
Highlighted
Active Member
Ivan M Member Since: Nov 18, 2016
140 of 155

Hi Ivo, you wanted to hear comments. 

 

I already tried to use your new app more than a year ago, but it was a skeleton of a program with no features, so I rolled back. 

 

Since I received message that the support for oDesk Team app will be discontinued this week, I decided to install the new app once again. So far I observed the following issues: 

 

- I still cannot adjust the length of snapshot preview or assign a custom sound that is loud enough for me to hear, like in oDesk app.

- The hotkeys only worked for one day and then just stopped working. They are still assigned and enabled, just do nothing when I press them (then need to be disabled and re-enabled in order to work). 

- I can't adjust the size of the cache. That's why the very next day after installation I woke up to see upwork site down, and time tracker cache full. Had no such issue with the previous version, thank you for my lost time/money. 

- I had to clear out some suspicious screenshots that should have not been in the tracked activity. Not sure how they got there, it might or might not be a quirk of the new app. Time tracker issues are both the most serious and hardes to spot/filter out, and I don't want to spend my own money on testing those.

- I sent a support ticket #16869420 and got a reply, but they didn't write back in more than 24h after my response. I imagine they are quite busy with other customers that are exploring the new app. Anyway, the support will not be able to increase my cache size or add features to the app, so I'm not complaining. 

 

On the plus side, the visual design has improved significantly and the messages feature can be hidden. 

 

So my question is: can your team give me the URL to download the previous tracker version? 

 

And my comment is: your new application is definietly not ready to be rolled out. Its current state after a year from release is somewhere between "major letdown" and "disappointment", it is still functionally a beta version. Please give it more time and use it to test out the bugs and add the crucial features, like cache size increase. Meanwhile, let us use the old tracker. 

TOP KUDOED MEMBERS