Showing results for 
Search instead for 
Did you mean: 

Feedback on the new Upwork Team App

Community Manager
Vladimir G Community Manager Member Since: Oct 31, 2014
141 of 155

Hi Ivan,


I'm sorry to hear you're disppointed with our Desktop app. I'll share your feedback with the team but would like to respond to some of the concerns you mentioned. 


Please note that users are notified when they are tracking time in caching mode and when their cache is full, after which the user won't be able to continue logging time until the cache is uploaded. The app needs a stable connection in order to quickly upload the cached time but note that the time-caching mode shouldn't be used on a regular basis, as it's not an alternative to the regular time tracking and can hold up to four hours of tracked time. If the cache was already full before the maintenance started that points to an issue with your internet connection.


I've been using the app for a year now on a daily bases and also have insight into other user's reports, and can confirm I haven't seen or heard about an issue with suspicious screenshots. I see you haven't shared this on your ticket so please feel free to provide screenshots, your app's log files and outline the segments which had the screenshots in question.


I also see you haven't shared the problem you mentioned having with the keyboard shortcuts, so please feel free to follow up on your ticket in order for our team to take a look.


Active Member
Ivan M Member Since: Nov 18, 2016
142 of 155

>Please note that users are notified...


Yes, I know. UPwork sent a email that it would be down for maintenance, and I decided not to switch the tracker off in the evening, I just put my laptop in hibernate mode - because otherwise would not be able to log in. Then I turned the laptop ON in the morning, and the tracker said that it is in caching mode (which is understandable) and then said its cache is full.


Had I used the old version, it would have been perfectly fine. 



>I haven't seen or heard about an issue with suspicious screenshots.


I have a feeling the new tracker doesn't have an "Away" mode. If I just stopped worked without turning it off, it continues tracking time - and it seems it interprets accidental mouse movements (not clicks) as activity, unlike the old version. Anyway, the old version knew when to switch the tracking off. The new one does not, and I had to delete those unwanted snapshots that even recorded some activity - though there clearly haven't been any (maybe the mouse cursor was moving by a fraction of milimeter when I was working on my other machine or moving, I don't know). 

I did not mention the problems on the ticket because they appeared after I sent my last message. I will probably update it later. At this point I had enough of discoveries and I'm just moving back to the old version on weekend.  

Active Member
Dmitriy S Member Since: Aug 17, 2016
143 of 155

Hi Vladimir,

I'm wondering is there any particular reason to abandon customers with RHEL7 and CENTOS7 (Latest possible RHEL based systems)  with version 4.2?


4.1 works perfectly fine with the OS, but 4.2 requires newer gblic and, I'm unable to use it.




Active Member
Kirill A Member Since: Dec 26, 2016
144 of 155


I have some troubles with upwork team app. It is freezing while tracking.

I'm using xubuntu 16.10 and upwork Version I tried beta version but result is the same. It starts lag when after it has been turned on.

How can I debug it?

Active Member
Sam K Member Since: Feb 8, 2017
145 of 155



Please tell me a way to save files both PDF and Images recieved on the UpWork ap for Android. It used to save these files automatically in the download folder but not anymore since i upgraded. 


Please advise. 

Community Manager
Valeria K Community Manager Member Since: Mar 6, 2014
146 of 155

Hi Sam,


Currently files can't be saved to a download folder on your android device. You can use use Google Drive or Dropbox to share files if you'd like to be able to open them on your mobile device.

~ Valeria
Ace Contributor
George J Member Since: Nov 9, 2014
147 of 155

I'm wondering if the dev team responsible for the Linux version could seriously consider supporting Red Hat 7/CentOS 7 along with Fedora and Ubuntu. The reason I ask is my Linux clients all use either RHEL or CentOS, not one uses Fedora or Ubuntu. Where this poses a problem for me is when I need to replicate a problem or start my work on my machines and then move it to their environment, I need to make sure everything I do is in an environment similar to the client's. This means I need to have a working Upwork client for CentOS7 which is where I do my work. I've been able to use the Team App with CentOS7 until recently. I have a laptop next to me with a fresh install of CentOS7 and I've just downloaded and attempted to install the latest team app only to find dependency issues where a couple of months ago there were none.


[root@zim ~]# rpm -ivh /home/dib/Downloads/upwork_x86_64.rpm
error: Failed dependencies: is needed by upwork- is needed by upwork- is needed by upwork-


Without the app functioning on my desktop I have to resort to using a Windows machine, VPN to the client's network, provision a VM for testing, and establishing remote sessions to that VM (desktop and multiple ssh sessions). My bandwidth is restricted to 5Mb/.5MB so this causes issues for everyone else here (my wife works from home and my two youngest kids are homeschooled). If I could get a functioning app I could prototype everything here in my environment and when the kinks are worked out move the config files and whatnot to the production environment.

Active Member
Sumit Kumar R Member Since: Jan 24, 2018
148 of 155


Why upwork donot keep older version of time tracker apps in the repository?  And why you apps are not backward compitable?

It is not possible for user to upgrde their OS every time. I am runnin in Fedora Linux 19. I cannot upgrade as a lot of application has been built .


Thanks and Regards

Sumit Kumar Roy

Community Manager
Vladimir G Community Manager Member Since: Oct 31, 2014
149 of 155

Hi Sumit,


Thanks for sharing your feedback. Note that while we do strive to have the Desktop app compatible with all Linux platforms, the focus is on Ubuntu as the most frequently used platform by Linux users. Officially the Upwork Desktop app is supported only on Ubuntu but we will aspire to have the app working smoothly on as many distributions as possible.

Ace Contributor
George J Member Since: Nov 9, 2014
150 of 155

Vladimir, I would respectfully disagree. I've done several Linux consulting projects through Upwork and not one time has my clients, or their end clients, ever used Ubuntu. It's been RHEL or CentOS (the majority of them). The problem is that your developers are basing what to provide to us by looking at what's popular on the desktop, especially for other developers, and not what's popular on the server side, which is where the jobs I look for are. In my 19 years of experience in IT on the infrastructure side I've only encountered Ubuntu once on a single test machine. It's been RHEL or CentOS with a smaller number of companies that use SUSE Enterprise/OpenSUSE (although those were absolutely huge deployments). Unfortunately, things that work one way under Ubuntu simply don't work the same way or aren't compatible (particularly libraries) under RHEL derivatives (including Fedora) and if your clients aren't using the same distro or a compatible distro and you're trying to test some things in your own environment before doing it in the client's environment you can end up with some serious issues costing you money, trust, and ultimately you can end up with a client looking at the whole Upwork experience skeptically.


Also, oDesk did maintain a repository of older releases of the team app for a long time. I believe that's something that could be valuable to many freelancers in a similar situation.