Reply
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Trying to Create Client Account but the Page keeps Loading. Please Help

Active Member
Waheed H Member Since: Jul 10, 2017
1 of 4

Hello Everyone, 

 

So, I created a freelancer account on this platform a few months ago and I want to create a client account. When I try to create an account after adding Company name the page keeps loading. I wrote to Upwork support 14 days ago. I have 

 

  • I have cleared my cache and cookies.
  • Tried a different browser
  • Tried my Office Computer as well 

But still, I'm getting the same issue. The disappointing thing is that I have been writing emails from 14 days now to the Support and every time I get the same message. We need more time we are working on the issue.

At this point, I feel I'm getting an automated message every time so I have come here to the community for some help.  Can anyone with more experience on this platform please help me with this?

 

Thank you!

 

Moderator
Goran V Moderator Member Since: Mar 24, 2017
2 of 4

Hi Waheed,

I`m sorry about the inconvenience this had caused you and would like to confirm that this is a known problem. Our engineering team is working on implementing a fix as soon as possible and one of our team members will update your ticket with more details. Thank you.


Untitled
Active Member
Waheed H Member Since: Jul 10, 2017
3 of 4

Thank You, Goran, Do you have any idea when this issue will be resolved or if it will be resolved because Now I'm very disappointed and hopeless. It keeps loading and the company is not able to resolve this issue. 

Moderator
Bojan S Moderator Member Since: Mar 9, 2018
4 of 4

Hi Waheed,

 

Unfortunately, we don`t have the exact ETA on this at the moment. We've followed up with our team about your concern, and they will get in touch with you via your support ticket once they have more information. Thank you for your patience.

 

~ Bojan
Untitled
TOP SOLUTION AUTHORS
TOP KUDOED MEMBERS