Reply
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Changing a profile picture

Active Member
Sean M Member Since: Nov 13, 2016
1 of 15

How do I change a profile picure in upwork?

Community Guru
Tamaz J Member Since: Nov 4, 2014
2 of 15

Sean,

Click on the picture in the profile.
It will open a window.
In that window "Upload Photo"...
That's it.

Thanks

Active Member
Masum B Member Since: Jan 6, 2018
3 of 15
 
Moderator
Vladimir G Moderator Member Since: Oct 31, 2014
4 of 15

Hi Sean,

 

Please go to your account > click the Profile tab > click on your photo > use the "Upload a different photo" link.

Active Member
Greg R Member Since: Apr 19, 2018
5 of 15
This doesn’t work.
Community Guru
Ryan C Member Since: Feb 3, 2017
6 of 15

Hello Greg,

 

Kindly go to your Settings, choose Account Info on the left side of the page, click your Photo and then click Upload a different image. Please see screenshot  attached for more info. Thank you.

profilePicSS2.png

profilePicSSS.png


Untitled
Active Member
Alastair G Member Since: Sep 19, 2018
7 of 15

So in the app I hover over my icon, it brings up 'add a photo now'. I click on it and it takes me to the Upwork web page with 'Password and security'. Nothing to do with uploading a photo. I'm confused. Where can I actually change my profile photo?

Active Member
Alastair G Member Since: Sep 19, 2018
8 of 15

When I click on 'My Info' it keeps bouncing to 'Password and security'. I.e. I cannot get to the My Info page that others can see. Here's my screen...

I'm sure many of you can't understand this as you don't get the same user experience however whenever I click on My Info it does not take me to that actual page. Is this a bug based on a few of my account settings?

 

Moderator
Avery O Moderator Member Since: Nov 23, 2015
9 of 15

Hi Alastair, 

Could you please try clearing your cache and cookies, or using a different browser to see if the issue persists? Please also try accessing this link. If none of this works, let me know so that we can look into this further for you. 


-Avery
Untitled
Active Member
Alastair G Member Since: Sep 19, 2018
10 of 15

Okay have cleared cache and cookies on Chrome. No luck. Have tried Safari. Same behaviour. Tried accessing the link - takes me straight to 'Password & security'. Basically whenever I click on 'My info' under 'Settings' it takes me back to 'Password & security'. My guess is it has something to do with my account being part of a corporate account? Perhaps I have less permissions than other users and the site is bouncing me because of it? I still think this is a bug.

TOP SOLUTION AUTHORS
TOP KUDOED MEMBERS