🐈 Community
msgaur
Member

Error 500 (A) while adding Billing Method

Hi

 

I am new to upwork and want to upgrade to upwork plus plan. To accomplish this I need to add a billing method. When I add a Debit card as my billing method it sends me an OTP. But after I fill OTP and submit it shows me error 500 (A) says "We cant complete your request now Please try again later". I tried several times (also with another card) but it gives me the same error. I really don't know what is the issue. It also gives a Trace ID below all the details but I don't know how can I use this ID.

 

Help would be appreciated

 

Thanks

 

ACCEPTED SOLUTION
egaruth
Moderator
Moderator

Hi Mohit,

 

Could you please try clearing your cache and cookies or using a different browser? Let us know if the issue persists so that we can assist you further.

 

Thank you,

~ Nikola
Upwork

View solution in original post

4 REPLIES 4
egaruth
Moderator
Moderator

Hi Mohit,

 

Could you please try clearing your cache and cookies or using a different browser? Let us know if the issue persists so that we can assist you further.

 

Thank you,

~ Nikola
Upwork

Hi Nikola,

 

Thanks for your quick response. I was trying it in Google Chrome. Now, following your suggestion, I tried it in private window in chrome but had the same error. Then I tried it in private window of Firefox browser. Still I got the error but at this time the error was quite readable and I was able to know the actual problem. The error was "Your bank was unable to verify your information. Please contact them and try again.". I think it is very clear that the problem is with my bank. I tried a different card and it has been added successfully. Your suggestion was really helpful.

 

Thank You

Hi I am getting this error. Pls help "There was an error loading this page: error [63bb7e0d8d6155e4-SIN, 63bb7e0d8d6155e4-SIN]. Contact Upwork Support for more information.

Close the alert

Hi Akhtar,

 

I checked this for you and was not able to replicate the issue you’re experiencing. Could you please clear your cache and cookies or log in with another browser to check if you’re still experiencing the same issue? Please use this link to see the options available to you and add one of those. 

 

Let us know if the issue persists.

 

Thank you.

~ Bojan
Upwork