🐈
» Forums » Freelancers » Re: I received Invalid date while receiving m...
Page options
yazanahmed0
Community Member

I received Invalid date while receiving my bonus.

I completed a milestone that contained a bonus, In the transaction window I can see my release date correctly but for the bonus, it's not there. My balance is also the same. How can I solve this? Or it is just a normal error.

 

Capture.PNG

3 REPLIES 3
petra_r
Community Member


Ahmed G wrote:

I completed a milestone that contained a bonus, In the transaction window I can see my release date correctly but for the bonus, it's not there. My balance is also the same. How can I solve this? Or it is just a normal error.


Give it some time. The date should become available within 24 hours of the bonus being successfully charged. It is usually a day after the milestone because the funds in esrow are already charged.

It is only something to be concerned about if nothing happens for several days.

gliaza25
Community Member

Hi good day, this is my issue also, just receive yesterday a bonus from my client and it says invalid date. It has been more than 24hrs already but its still the same. Does my client needs to do something? Bec he said on their end there is no notification from upwork that he needs to do.

Hi Gliaza, 

 

Sorry about any confusion that can cause you. Please note that all manual payments, including milestones and bonuses, become available 5 days after the payment is successfully processed. You can check this help article to learn more.

 

Thank you.

~ Luiggi
Upwork
Latest Articles
Featured Topics
Learning Paths