» Forums » Freelancers » New Tracker Not Tracking Aug 2018
Page options
Community Member

New Tracker Not Tracking Aug 2018

New tracker auto installed last week.


On Friday it did not track automatically so I had to add hours manually.


Now, today, it has not recorded about 4 hours and won't allow them to be added manually either, just returning to the manual screen each time. It does not show the hours already worked in the list of times either, like it used to do.


This is a show-stopper, I'm not going to work if I'm not going to get paid. I see that your server is also having problems 'again'. Are you working on fixing the tracker?


283 REPLIES 283
Community Member

I have the same problem, but with windows 10, I NEED TO WORK and it says that connection failed, but my connection is working petrfectly! Can someone tell me how to solve this problem? Minimum i disinstalled and reinstalled the app 5 times, beta version and older versions.

I am also facing same kind of error. Not able to log in and track time.

Community Member

Right now time tracker app isn't working. I can't log in and I'm not the only one...

Community Member

My Upwork desktop app is not working. First it kept losing connection, while tracking working time. After reading some advices here, I reinstalled the app and restarted my computer, now I can't even sign on because the app fails to connect online. 

I didn't mention the connection being lost issue, because it only happened last week and I was told it was a server problem, not a tracker problem.  Today, I have not seen the Tracker Disconnected notification, just a lack of auto-tracked hours and the inability to add these hours manually.


Perhaps Upwork have more problems than they know, it won't let me respond with saying correct the highlighted errors, and there is nothing highlighted. 

I cannot work due to downloading this new timetracker app. It is very important you give us a way to roll back to the previous working app. Also tell us how to stop automatic upgrades. I now cannot even log in to the timetracker. It says "unknown error". At first it would not track time today now I can not even log in.. I need to work urgently.

Same here. I could not log-in to desktop app after the update, but log-in to the website is perfectly fine. 

Community Member

Same issue here - lost connection after update and neither reboot no reinstall didn't help.
When it will be fixed?

Hello! I can not connect from time tracking application with server today. My OS is windows 8. Please, help.

**Edited for Community Guidelines**

Hi All,


We apologize about the inconvenience this has caused you. We have an active incident at the moment and our team is working on solving it as soon as possible, if you would like to follow our updates about this check out our Status page here.

Just to confirm that the desktop app can store up to 4 hours in cache mode, once the app is reconnected with the website your time will be uploaded as well. Thank you.

~ Goran

@Goran V

I have been online all morning, with the tracker running. It did not track my hours!

I have not been disconnected, I have not had the Tracker Disconnected message, so this is not a problem of the tracker being disconnected and not storing in cache.


Also, what has this got to do with no times showing in the list, and the tracker not allowing manual time to be added either? No message, no errors, just nothing.



I'm having a similar problem since last night. Time is added to the session counter but not to the global time. Screenshots are not taken and worked time does not add to the daily session. 


Last screen shot was taken 15h ago. 



Hi Jose,

Please open a ticket from your app as this will attach your logs and our team will be able to investigate it further. To do this click on the Settings Cog > Support And Feedback. If you need further help from me let me know, thank you.

~ Goran

Thanks Goran, 

I did send a message through the app yesterday and I'm wating for a reply



It's down for 6 and a half hours. If it can cache 4 hours only, my salary will be affected by your mistake. Is there a way for this to be fixed?

Hi Nikola, 

With our new update on the desktop app the cached mode capacity is also raised to 12 hours. Feel free to continue working on your contracts. Thank you.

~ Goran

"With our new update on the desktop app the cached mode capacity is also raised to 12 hours. Feel free to continue working on your contracts. Thank you."


Unfortunately, since you removed the timer that tracked the current session, we have no idea how long we've worked.

I agree, removing the current session does not improve this app.


Put the current session back in.

If you cannot connect to your server, don't drop to zero, keep the last known total hours, and count offline so we can see what we're doing.  Telling me that it will happen later, when all I can see is zero hours for the entire week is a very poor user experience.


Here's an idea, hire some freelancers to do the work for you, then perhaps your app will be fit for purpose.

Same here we can't track the time and the work.  This is not free, this may cause of nothing.

Hi sir, I'm experienciing the problem also, but I uninstalled and reinstalled the time tracker because I thought it will solve the problem not knowing that my hours of work done will be deleted also, I have already 9hrs of work done, is my time already recorded on the main site?

Go and check your Work Diary

The status page says everything is operational but I still can't log in. The app is still showing "An unknown error has occured."

why does the time app not work?. It shows an unknown error.

This is a very strange decision to update the product with bugs.

How do you think what will freelancers think after this case about the professionalism of the Upwork?

P.S. I still can't log in.

But if you restart the app then the time tracked that has not yet been uploaded will be lost, is that correct?

When is this going to be fixed I still have the error can't sign in at all ...It's been 2 hours now for me are going to fix this today??????

Hi I need help finding the auto time tracker and then figuring out how to use it. Thanks for your time. 

Hi Jennifer,

To learn more about our desktop app check out this Help Article, if you have any additional questions feel free to post them here. Thank you.

~ Goran
Community Member

Same experience as last week and just now as I tried to log in to the tracker I cant log in. It's saying "Check Connection" although I have a very good internet connection. I hope they will take action on this immediately.

I'm having the same issue since upgrading to the new app. I can login fine here, but when I go to do so on the app, it just tells me "an unknown error has occured". Sorry I can't give you any more info than that. It does this no matter what OS I use - my laptop has windows 10 and my desktop has windows 7. 

Community Member

Hello. I am trying to log in the Desktop app, but it writes that there is no connection. But I have stable connection to the Internet. What should I do?

Yes, I am also facing same kind of error. Not possible for me to log in and track time.

Community Member

Me too. Version 5.1.0.*** , updated yesterday

Experiencing the same issue on v.


Please fix ASAP 

I have similar issue, I can't login  " An unknown error has occured".

New tracker auto installed few hours ago. I just went to log onto the time tracker and get an error "An unknown error has occurred".

I cannot log in to Upwork it's giving me an error "Unknown error has occurred". I'm using mac

I can't log in to my time tracker " An unknown error has occured."

Hi All,

Unfortunately all users that were not logged in before the incident started will not be able to log in until it is resolved. 
We apologize once again and thank you for your understanding while we're working to resolve the issue as soon as possible. 

~ Goran
Latest Articles
Featured Topics
Learning Paths