๐Ÿˆ Community
tmcdos
Member

New bugs/glitches with the UI

Yesterday I decided to apply for a job and I opened the dialog for creating a proposal - the text fields had no borders.

I reported the bug (it's a bug, is not it - does it make sense to write text in the void?) and the answer was "this is by design".

99% of forms on the web either have bordered text fields or at least a bottom border (if they follow Google Material design principles) - and here we suddenly have no borders at all. Because someone (I have no clue whether this decision comes from a manager or from a designer) decided that text fields will be better without borders.

 

shot-1.png

 

Then I decided to make a tiny update to my overview. I opened my profile and the characters counter below the text field suddenly shows a negative number. How is this possible? This overview has already been created 4 months ago - and back then Upwork happily accepted it.

I reported the bug and the reply was "This field has a limit of 5000 symbols". I counted the symbols in two different text editors and the number is 4170 symbols. Obviously there is something wrong here as 5000 minus 4170 is certainly not -1119 ...

 

shot-2.png

17 REPLIES 17
759e32fa
Moderator
Moderator

Hi Ivaylo,

 

Thank you for reaching out to us. I checked this for you and I was not able to replicate the issue. I see that the text files have borders and the word count did not show a negative number. Here's the screenshot that I took. 

 

This could have been a minor glitch but thank you so much for reporting. If we get several more reports, we will proceed to investigate the issue. 


~ AJ
Upwork
firescue17
Member

The character cap in the overview has been around for two years. I haven't been able to edit my profile for the same reason. Wait until you find the sections with a 500-character cap. Some of the new features are great useless for this very reason.

tmcdos
Member

Today I tried to add video to my profile - and I again stumbled upon the same bug, 2 weeks later. I reported the bug again and the support said it looks like "latency" and that this behavior is not yet confirmed as a "real bug". For 2 weeks ....

To be honest, the other bug with the missing borders of the text fields was fixed in about 2 or 3 days.

**Edited for Community Guidelines**

tmcdos
Member

After escalating the problem, the response is even less helpful:

**Edited for Community Guidelines**

 

Such a pity:

1. The overview has been already saved once - which means that it was not considered "too long" by Upwork or otherwise I would not have been able to save it in the first place.

2. Yet when I open it - Upwork says it is 1119 symbols more than the allowed 5000 (which number the technical team was unable to determine) even though the overview is 4170 symbols long and this is safely below the limit.

3. Upwork refuses to confess this as a bug despite the obvious evidence - they claim that this wrong number (-1119) is actually expected and normal.

4. Their advice to me is that my overview should be no more than 250 symbols. I would not be surprised if 3 months later they start advising us to stay below 160 characters.

 

It's bad user experience, and not the first time.

tmcdos
Member

Another glitch today when attaching images in the chat.

1. I type a chat message, attach an image and click SUBMIT

2. Literally 3 seconds later I try to attach another image - it seems attached because there is a thumbnail in the chat but you can not click on the thumbnail and see the image in its original size

3. I deleted the failing image and attached it several times - and the behavior is repeatedly consistent

4. I opened the DevTools of the browser and noticed that as soon as the image is uploaded to Amazon S3 in the background - the frontend UI issues a DELETE command and deletes the image from Amazon S3 that it just uploaded

 

Ridiculous.

 

shot-2.png

tmcdos
Member

Today I found another bug

shot-1.png

Hi Ivaylo,

 

Thank you for reporting these to us. I'll share your feedback with the appropriate team so we can get this resolved.


~ AJ
Upwork
tmcdos
Member

If you try to post a chat message containing something completely innocent and harmless like `SKU/bin/category/supplier` you will trigger the Web Application Firewall in CloudFlare and it won't let you post the chat message. Either avoid typing the word "bin" or replace the forward slashes with vertical bars and even add surrounding spaces.

tmcdos
Member

The new version of Upwork Messages does not support the triple backticks Markdown construction. If you want to paste some piece of source code (e.g. the template of a Vue component) - Upwork will strip the HTML tags from your chat message thus rendering it completely useless. This is another example how something working is replaced with another broken thing.

 

It is a complete mistery to me why there are so many bugs on a platform which has access to the largest pool of developers.


Ivaylo G wrote:

It is a complete mistery to me why there are so many bugs on a platform which has access to the largest pool of developers.


/giggles๐Ÿ˜…๐Ÿ˜‚๐Ÿคฃ

ETA: it's also curiously giggles why every platform in the entire world doesn't require the knowledge and use of HTML to insert and edit emoji. It's a wonder ne1 makes any money nemore.

The new version of Upwork Messages (most probably because of the Web-Application Firewall in CloudFlare) also does not allow posting SQL queries in the chat.

tmcdos
Member

shot-2.png

tmcdos
Member

More bugs with the new version of Upwork Messages - inconsistent and sometimes just plain broken image attachments in the chat.

First, how the things look in the new chat - image (1) is shown properly, image (2) has only a thumbnail but no large size image (you can not click on the thumbnail) and image (3) is shown as regular attachment without even a thumbnail:

 

 

 

When you switch to the old version of Upwork Messages, everything works fine:

 

**Edited for Community Guidelines**

Hi Ivaylo,

 

Thank you for sharing additional information. While we can't allow those screenshots as they contain private info, I assure you that I will share you'll feedback with the appropriate team. 

~ Nikola
Upwork
tmcdos
Member

Today I was faced with a CORS error when opening the Upwork Messages - apparently https://www.upwork.com is not allowed to access https://tl.upwork.com

shot-1.png

Hi Ivaylo,

 

Thank you for reporting this to us. I'll share your report with our team for review.


~ AJ
Upwork
tmcdos
Member

It is a complete mistery to me how Upwork Messages decides whether to show a preview/thumbnail for an image attachment or not. Below I've attached 2 different images in the chat - the first is shown as a generic file attachment (file size is 4620 bytes  PNG and image dimensions are 695x64) and the second is shown as a thumbnail (file size is 32906 bytes PNG and image dimensions are 1247x276).

shot-3.png

Learning Paths