🐈 Community

Time Tracker Update Not Working

This morning on opening the time tracker I was informed there was an update. There was no option to skip this and start work using yesterday's version so I clicked "update".


The app has now been "installing" for an hour.... with the inane message "Here we go! If the app closes, don't panic. We're just updating the app."


I closed it and tried reinstalling the tracker but again I am forced to update and it doesn't work. It is still "installing".....


I have clients waiting for me to start work. 


Can someone advise?


+1 here. I left support request and forum message 6 hours ago, and no positive result so far. Team app is clearly not functioning right now. I wondering if Upwork will compensate us lost time.


Actually I advise you to leave the support request too so they know about the problem and that this problem affects a group of people.




I think I just found a (temporary) solution for my system. Can you say, do you use OSX by the chance?



I am using mac. When I open Upwork, the app tells me there is an update available. But it wont download the update through the app. So I go to the website and download - but the download is still on the old version. 


So I cant update through the app, and the current download needs to be updated! I can't get it to work at all. 



Hello everyone,


I downloaded the Upwork app(for hourly tracking) and the download was successful. But after the installation process, my pc freezes and I'm forced to restart my pc manually. My friend has a laptop and his upwork is up-and-running, so I copied the whole app file from his laptop to mine. I used the copied app and it still freezes. The laptop I'm using is still brand new. It didn't/doesn't freeze till I use/install the upwork app. Please help. Thanks.  

I had the same issue a while ago. I solved it by deleting the tracker from my computer, and reinstalling it again. Worked perfectly after that.