🐈 Community
» Forums » Freelancers » Time Tracker is not working
Page options
hvillapuz
Community Member

Time Tracker is not working

I've installed and uninstalled the Upwork timetracker for more than 10 times and yet it is still not working on my Mac. Everytime I click it, it's not opening. No window whatsover. I'm not sure what's wrong here. 

 

My macOS is Ventura 13.0.1

Is the Timetracker not compatible with my macOS?

 

Can someone please help. I need to have this issue resolved asap as I have some work to do. Thank you!

4 REPLIES 4
25005175
Community Member

Contact support, tell the chat bot that they haven't fixed your problem a few times, then it will connect you with an agent.

 

And, um, after installing the program, have you restarted your Mac?

 

25005175_0-1668642935774.png

 

I can't get past the bot. It's not connecting me to an agent. Just keeps repeating the choices.

 

I restarted my mac after installing the program but still no luck. Kept uninstalling, reinstalling, restarting the mac, and nothing. 

812dd08c
Moderator
Moderator

Hi Hazel,

 

Thank you for reaching out. If you are unable to log time on an hourly contract listed in the app, please close the app and log in to your Upwork account from your internet browser. Then, clear your cookies by going here and restart the app. You may also want to check this help article for the known fix on your Desktop App.

 

~ Arjay
Upwork

Hi Arjay, this doesn't fix the issue. I need technical help as all the articles doesn't provide any solution. Can I please talk to an agent? It would be faster that way. 

Latest Articles
Upcoming Events
Jan 31
Feb 28
Upwork Community Virtual Hour
Community Hour English
Learning Paths