» Forums » Freelancers » Time Tracker window is Missing, Not Showing ...
Page options
Community Member

Time Tracker window is Missing, Not Showing Up

hi gurus I am trying to open my desktop Upwork app but it's not showing a tracking window showing me the messages and contact list windows I have reinstalled the app restarted the laptop twice but failed to load the tracker window I have tried already by opening the app from taaskbar
i am using windows 10


Hi Nisar,


Could you please try the troubleshooting tips shared in this help article? If the issue persists, please report it following the ''How do I report a problem?'' section of the previously shared troubleshooting guide, and our team will assist you directly.


~ Nikola



I am having the same trouble as well, I'm using a Macbook I tried re-installing it twice but still the tracker won't show up. I hope you can help me as soon as possible with this issue. 


Kind regards, 


Hi Katherine,


Could you please try following up on these steps and let me know if they worked for you?


  1. Uninstall the application
  2. Open the terminal app​
  3. Run this command tccutil reset All
  4. Then run this command mv ~/Library/Application\ Support/Upwork{,.bak}

Thank you.

~ Aleksandar

Hello Aleksandr! 


Great! It worked! I appreciate your help! 

Warm regards,



So I accidentally close the time tracker with the key commands when I am multi-tasking. I have had to go through this process several times now and to be honest it gets really annoying. Is there a fix to this issue in the development queue at all? Its obviously an ongoing issue for many of us. And we shouldn't have to run terminal commands each time just to get it to fix. Just uninstalling and reinstalling the app never works for me.


Surely there is a way the developers of the app can permanently fix it, no?

Hi Sarah,


I shared your report with our team and one of our agents already reached out to you directly via a support ticket to assist you further. You can access your ticket on this page.


~ Nikola
Community Member

It's still not fixed. You'd think with the amount of money your company takes from us, you could make your apps function properly. Both the desktop and phone app are buggy. I wasted the whole day looking how to get my windows back. Your online portal is horrible too. Your bot had no clue what I was talking about and didn't connect me to a person when I asked.

Hi Benjamin,


I'm really sorry for the inconvenience. I can see that you have already submitted a ticket to our team. One of our agents will update your ticket and assist you directly.

~ Joanne

I totally agree. This is a HUGE app UI fail. Is it so hard to have "Open Time Tracker" in the Window menu? Or, perhaps, a simple button on the messages window? Maybe a small toolbar or something. Jesus. This is such a pain in the ass. Every time I forget and close the time tracker window I have to WASTE time searching for the fix. Grrrrr

Luckily it hasn't happened to me since my post, however, I have since learned that from the Messages window (which of course is always available, but I digress) the key command to bring the timer back up is (if on a mac, not sure about PC) control + option + t. 


The caveat to that is you have to have the keyboard shortcut turned on. HOWEVER, if you don't you can access the menu by clicking on your photo in the bottom left of the messages screen and bring up the settings menu.


You would think it would be a default and not even be able to be closed, but what do I know? I just work here. = )

this is the best solution so far.  you can change your shortcut as well

I need help as well, my upwork tracker wont open as it just keeps loading for hours

Community Manager
Community Manager


Hi Doris,


Thank you for reaching out. I can see that you've already raised a support ticket regarding your concern. You can access your support tickets here. Note that support requests are responded to in the order they are received. Kindly allow 24-48 hours for the team to follow up with you and assist you further.


Community Member

It's been 3 years and the issue is still there! I am on Mac and keep having this issue, installing and uninstalling the app. Ridiculous!!

Hi Alexandra,


I am sorry to hear about the trouble loading the Desktop App on Mac. Could you please try Troubleshooting tips shared in this help article.  If the issue persists, please report it following ''How do I report a problem?'' section of the previously shared Troubleshooting guide, and our team will assist you directly. 


- Pradeep

Latest Articles
Top Upvoted Members