🐈 Community
e84920fc
Member

Time tracker - download not working (Windows 64)

Hello all, I'm a freelancer and I'm just starting with upwork.  I downloaded the time tracker app - I tried both Standard and Beta versions for windows 64 - but after installing it when I click on run, I need to login into my Upwork account and after a verification (code sent to my mobile nr), a window opens but it keeps loading and it never finishes the download (it just says "one moment please", but even after 30-40 minutes nothing happens). 

 

I already:

-checked other topics in the community

-checked the instructions from support page for troubleshooting the issue

 

Unfortunately nothing helped. I added the app to the system's firewall, I tried several times (always uninstalling the previously installed app first), I tried with both standard and beta versions.  But whatever I do, it's always the same, when clickling on "run" I can only login into my account and after the verification step it just never finishes. I also checked on "how to report a problem" , in order to contact support directly but I don't see this option on my upwork page on browser neither in the mobile app.

Any suggestions?  Thank you very much!

7 REPLIES 7
g_vasilevski
Retired Team Member
Retired Team Member

Hi Natalie,

 

Please go to Settings > Connected Services > and disconnect your Google account. Once this is done try to log in using your email/username and password. Thank you.

~ Goran
Upwork

Thank you, but when I click on connecting services on Upwork account settings I don't see an option to disconnect my google account. I see only "password" where it says I'm using my google sign- in (but there is no option to disconnect) and the other options are only to add extra layers of security, see attached.  Or should I remove the access to upwork on the Gmail settings?  Will I then still be able to login into upwork? Thank you!

Hi Natalie,

Once you remove your Google account you will still be able to log in on Upwork. But you will need to do this from the correct section (Connected Services) under your Settings. Thank you.

~ Goran
Upwork

When I click on "connected services" in the settings, it directs me to password & security.  I tried to open the section on a new tab and also just click on "connected services" but it directs me to "password & security" .  I checked with the cursor on "connected services" to see the address and typed manually the address as shown (www.upwork.com/ab/my-info/connected-services), as per screenshot.  As soon as I click on it, it comes password & security section.  So upwork is redirecting me from connected services to password & security.   


After I click on "connected services" I see a message "bam.nr-data.net" , I'm not sure if this is a blockage.

Thank you for the clarification Natalie,

 

Our team will investigate this further from our end and one of our team members will reach out to you via ticket to assist you further. If you have any additional questions, let me know. 

~ Goran
Upwork
finite23
Member

Same problem at my end. This install, re-install, retry etc. is quite outrageous given that I am subsquently currently in a contract dispute on Manual Hours earned (goodluck to me on that). Particularly when ~10% or thereabouts is scraped off the top of earnings for the creation of a marketplace & "the security of dispute resolution". Why is a linking to Google Accounts allowed if it is still buggy and poor performing? Jumping off this often cumbersome platform and working on my own is looking more attractive every day. Thanks!

Hi Lucas,

 

I`m sorry about the inconvenience this had caused you. Could you please confirm the exact problem (error you`re receiving) you`re having with the desktop app so that I can assist you further? Thank you.

~ Goran
Upwork
Learning Paths