Showing results for 
Search instead for 
Did you mean: 

Re: Unable to submit proposal

Joanne Marie P Moderator Member Since: Nov 26, 2017
341 of 557

Hi Gerald,


Sorry to hear about the trouble, but we're glad to know that it's now working. 

Active Member
Zhivko G Member Since: Oct 6, 2018
342 of 557

Hi Joanne,

I am experiencing the same problem: I updated my address, and I still can't send Job proposals. Can you please help? Thanks.

Bojan S Moderator Member Since: Mar 9, 2018
343 of 557

Hi Zhivko,


One of our team members will reach out to you shortly and assist you further, thank you!



~ Bojan
Active Member
Saurabh G Member Since: Nov 1, 2018
344 of 557

I am also facing the same problem. Please help.

Goran V Moderator Member Since: Mar 24, 2017
345 of 557

Hi Saurabh,


Please go to Settings > My Info and add your address and your phone number. If you`re still experiencing the same issue after this let me know, thank you.

Active Member
Michael S Member Since: Nov 11, 2018
346 of 557


Active Member
Gena A Member Since: Mar 12, 2019
347 of 557



I have done this 2x already but i still get the message

i tried logging off and on 2x too but it doesnt help


Can a Staff Member get in touch with me to solve this problem? i cannot apply to any job! 

Goran V Moderator Member Since: Mar 24, 2017
348 of 557

Hi Gena,


Just to confirm that you still haven't added your city in your address, to do this please go to Settings > Contact Info > Location. Thank you.

Active Member
Gena A Member Since: Mar 12, 2019
349 of 557
Fixed! Thanks!
Had to wait for a suggestion of the city to come up and click it.
i wonderd why i diddnt save the city the first time i put it in

thanks again
Ace Contributor
Brittany J Member Since: Jul 11, 2016
350 of 557

Yup, there is definitely something going on, I keep getting the error message for location even though my location is correct.