Showing results for 
Search instead for 
Did you mean: 

To submit a proposal, update your address

Community Guru
Gerald S Member Since: Apr 1, 2018
301 of 464

Is anyone else experiencing the message "Sorry, we are unable to save your application" when submitting a proposal. Current time is 2:27pm Central Standard Time.

Active Member
Tim F Member Since: Oct 4, 2018
302 of 464

Hi, ya, I can't even get to the proposal stage; I keep getting access denied, no post profile (or something like that), or a page saying it's not available at my location (it should be). Seems something's wrong with the proposal process.

Community Guru
Gerald S Member Since: Apr 1, 2018
303 of 464

My forth attempt finally went through.

Joanne Marie P Moderator Member Since: Nov 26, 2017
304 of 464

Hi Gerald,


Sorry to hear about the trouble, but we're glad to know that it's now working. 

Active Member
Zhivko G Member Since: Oct 6, 2018
305 of 464

Hi Joanne,

I am experiencing the same problem: I updated my address, and I still can't send Job proposals. Can you please help? Thanks.

Bojan S Moderator Member Since: Mar 9, 2018
306 of 464

Hi Zhivko,


One of our team members will reach out to you shortly and assist you further, thank you!



~ Bojan
Active Member
Saurabh G Member Since: Nov 1, 2018
307 of 464

I am also facing the same problem. Please help.

Goran V Moderator Member Since: Mar 24, 2017
308 of 464

Hi Saurabh,


Please go to Settings > My Info and add your address and your phone number. If you`re still experiencing the same issue after this let me know, thank you.

Active Member
Michael S Member Since: Nov 11, 2018
309 of 464


Active Member
Gena A Member Since: Mar 12, 2019
310 of 464



I have done this 2x already but i still get the message

i tried logging off and on 2x too but it doesnt help


Can a Staff Member get in touch with me to solve this problem? i cannot apply to any job!