Reply
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

To submit a proposal, update your address

Active Member
Evgeniy K Member Since: Sep 26, 2018
31 of 377

I already wrote about this problem. How long does it take to fix it? I can not make a proposal

Active Member
Victor Y Member Since: Sep 28, 2018
32 of 377

Same problem:

Sorry, we were unable to save your application.
You must update your address before you can submit proposals

 

Active Member
Jordan B Member Since: Sep 28, 2018
33 of 377

Hi good day!

I am having same Issue : error message "To submit a proposal, update your address"- I already updated my address. pls help.TIA

Active Member
Leonardo F Member Since: Sep 27, 2018
34 of 377

Hello Valeria,

 

I still have this issue, any update regarding this?

 

Thanks.

Active Member
Fizza N Member Since: Feb 24, 2019
35 of 377

I'm having the same problem. i have updated my address and location twice, done everything i can think of. Can you please see my profile and tell me what i can do to start submitting proposals? It still says i have to update my address to submit proposals.

Moderator
Goran V Moderator Member Since: Mar 24, 2017
36 of 377

Hi Fizza,

 

I checked your account and was not able to replicate the issue, could you please try clearing your cache and cookies or using another browser? If you`re still receiving the same error let me know what type of browsers you have tried to use, thank you.


Untitled
Active Member
Cassaundra T Member Since: May 11, 2019
37 of 377

I am currently having this issue and was wondering how long this has been going on

Moderator
Riri A Moderator Member Since: Jul 21, 2018
38 of 377

Hi Cassaundra,

 

I see you've also followed up via our social media channels. One of our team members will reach out to you shortly and assist you directly with your account. Thanks.

~ Riri
Untitled
Active Member
Alex M Member Since: Sep 27, 2018
39 of 377

I faced the same problem. Please help to deal with it

Active Member
Hossein R Member Since: Sep 27, 2018
40 of 377

I have this issue as well.

My profile is completed but it gives me the same error when I want to submit proposals.

 

Please somebody help!

TOP SOLUTION AUTHORS
TOP KUDOED MEMBERS