Showing results for 
Search instead for 
Did you mean: 

Unable to Submit a Support Request

Active Member
Ekaterina M Member Since: Sep 20, 2017
1 of 19


I am unable to submit any request to Support. 

The sample screen grab is attached. Once I type in my question and click on 'Next' the window 'Get Help from Upwork' simply disappears. Requests don't appear in 'My Requests' page in my Support profile.

I tried doing this form different web browsers, same result.


When I click to support link from other pages (not my profile), they direct me to a third page, and then redirect within a mere second to this landing page where I face same result as described above.

Please advise how to submit a request to Support?



Avery O Moderator Member Since: Nov 23, 2015
2 of 19

Hi Ekaterina, 

We're sorry if this has been very inconvenient for you. Is there anything we can help you with? 

Active Member
Roman G Member Since: Sep 20, 2016
3 of 19

Same problem, can't submit a request. I need to sign the document for my bank as soon as possible, but support is unavailable. Please, help with this.




Vladimir G Moderator Member Since: Oct 31, 2014
4 of 19

Hi Roman,


I'm sorry to hear about the problem you're having with contacting Customer Support. Could you please try clearing cache and cookies, using the incognito mode or a different browser and confirm if the submit button is still inactive? 

View solution in original post

Active Member
Roman G Member Since: Sep 20, 2016
5 of 19

Tested - seems now it works. Thanks for the help!




Active Member
Igor M Member Since: Oct 16, 2017
6 of 19

Hello, i have the same problem - can't submit a request.

i have already tryed different OS and browsers.

Please advise how to submit a request to Support?

Vladimir G Moderator Member Since: Oct 31, 2014
7 of 19

Hi Igor and Raushan,


If the above-mentioned actions are not helpful, you can try using a proxy which helped some freelancers from your country who were having similar issues to use the available support options.

Active Member
Arun K Member Since: Aug 10, 2009
8 of 19


I am trying to create a support ticket but I am getting the attached message with a Back button only. I have tried using USA VPN location also, but issue stay the same, there is no option to complete and submit the request to support.

**Edited for Community Guidelines**

Goran V Moderator Member Since: Mar 24, 2017
9 of 19

Hi Arun,

I just checked your account and can confirm that you`ve managed to open a ticket with our customer support, you can access your tickets on this Link
If further help is needed let us know here or feel free to send us (Moderators) a PM if private details are involved, thank you.

Active Member
Raushan G Member Since: Oct 16, 2017
10 of 19

Hello! Have the same problem. Using other browsers or incognito mode, cleaning cache and cookie didn't help. Are there any other solutions of this problem?