Showing results for 
Search instead for 
Did you mean: 

Re: Unable to Submit a Support Request

Active Member
Valeriy Y Member Since: Jun 2, 2020
11 of 19

I have a promlem - I can't submit a support request. I only see my previous request, but don't have a button to create new one.


I have and issue - I've created Agency and add my collegs, but I can't add averyone because of:


1. For 2 of them it shows me and error - "has active job applications" - what should I do here?

2. One of them get invintation link, but when he go through it - nothing happens

3. One of them I've just got an error - failed to invite


I need support request for this question to share e-mails of this collegs, that you have a chance to check them

Goran V Moderator Member Since: Mar 24, 2017
12 of 19

Hi Valeriy,


1. Please aks your freelancer to close his active and archived proposals. Once this is done you can try to send them an invitation. 

For 2 and 3, our team will reach out to you via ticket as soon as possible and will assist you further directly there. Thank you.

Community Guru
Isabelle Anne A Member Since: May 19, 2014
13 of 19

Several freelancers have been experiencing this and a week ago I saw this message on the main help page:


"We are aware that some users are not able to submit requests to customer support right now. Please know our engineers are working to resolve the issue. We apologize for the inconvenience."


Obviously it's an Upwork problem - why do we have clear cache, cookies, use diff browser, use proxies, etc.?



Ace Contributor
Alexander O Member Since: Apr 26, 2016
14 of 19
Hello everyone, Probably that's incorrect place for to ask, but: anyone have any such troubles? I've tried to send them feedback, help request, support request and - nothing is works at all. So I'm not sure: is it only for me or?
Community Guru
Isabelle Anne A Member Since: May 19, 2014
Vladimir G Moderator Member Since: Oct 31, 2014
16 of 19

Hi Isabelle Anne,


Could you please share a screenshot of the message? If you're referring to the status blog it's possible that an issue we might have had at that moment affected this process. Otherwise, as shared before, some freelancers from Russia did report having issues with contacting Customer Support. For some, the issue was resolved by following the steps you mentioned and others were able to use the available support options after using a proxy. Our team did investigate but so far, based on the limited number of freelancers who responded to our requests to provide more information, it looks like the root cause is related to the server and not to processes on our end.


Let us know if you're also experiencing these issues Isabelle so we can take a look.

Community Guru
Isabelle Anne A Member Since: May 19, 2014
17 of 19
It wasn't on the status blog; it was on the main help page through which one submits tickets. It's not showing anymore for me but I did mention it in another thread:

Valeria is following up on the issue I tried to report, so I don't want to open another ticket unnecessarily, but will report back here if I'm unable to submit a ticket later on.
Active Member
Nikita G Member Since: Oct 17, 2017
18 of 19



I have the same issues. I've tried different options that was mentioned above (clear cache, different browsers, incognito mode, proxies), but still can't submit request. Is there anything else that i can try?

Vladimir G Moderator Member Since: Oct 31, 2014
19 of 19

Hi Nikita,


I checked and was able to submit a support request while using your account and see the most recent request you submitted was about ten days ago. Please follow the steps shared above and contact us via private messages on Facebook or Twitter if you're still unable to submit a request.