🐈 Community
» Forums » Freelancers » Upwork Desktop App Won't Launch
Page options
Community Member

Upwork Desktop App Won't Launch

Hello everyone,

I'm having an issue that my Upwork Desktop App won't open.
I've tried to perform all solutions that I could possibly find online (from the community forum & troubleshooting options menu) yet still no result.
I also noticed that the desktop app is running when I check in the task manager unfortunately it just doesn't show up.
I'm using Windows 8.1 pro and Upwork App version

Please kindly help, thank you.App Issue.jpg


Hi Nur,


Can you please confirm if you're still experiencing the same issue after following the troubleshooting steps provided in this help article? Let us and we'll look further into that for you.


~ Arjay
Community Member

Hello Arjay,

Thanks for the reply!

I've followed the troubleshooting steps provided in the article and still cannot solve the issue.

Even so strangely, when performing the: "How to completely delete the Upwork Desktop App's cache", it resulted in the app completely cannot be opened (as in the app being uninstalled) after I deleted the folder as shown in the steps (did this steps for several times).

Is there another solution? Please, help.

Community Member

For further information, this issue happened after I upgraded my device from HDD to SSD that I also performed a data migration (so that I don't have to reinstall the OS and other programs). The upgrade and data migration process were successfull and my device works normal as usual (other programs run normally) until I tried to open the Upwork desktop app and encountered the issue. Hope this information helps.

Hi Nur,


Thank you for your message. I see that you have already initiated a support ticket for the same inquiry. One of our team members will reach out to you as soon as possible to assist you further.


Thank you,


Latest Articles
Upcoming Events
Jun 22
Upwork Virtual Community Hour
Community Hour English
Featured Topics
Learning Paths