» Forums » Freelancers » UpWork app stuck at loading.
Page options
Community Member

Upwork desktop app issue when starting

Hi, im trying to start the desktop app but the app just stays loading, i tried uninstalling it, but i think there still some data to delete somewhere. tried open as admin and the same result.


some idea?


current version installed: v.5.4.71



EDIT: the app starts but nothing else happens just keep loading.

Community Member

Hi All,


We'd like to confirm that the issue has been resolved. To launch the App, you may need to  shut it down or "kill" it via system tools. On Mac it can be done via Activity Monitor utility. On Windows you will need to open Task Manager, find Upwork under Processes tab, select, click End task.

~ Valeria

View solution in original post

102 REPLIES 102
Community Member

Same here. It's just stuck on loading permanantly. Going to have to do manual time today until it can hopefully get fixed.

Community Member

same problem encountered here.

Community Member

Same for me. Can somebody please help us. I am working on a time sensitive project.

Community Member

Status page is not mentioning anything either ...




yes, this seems like a software issue, tried to find another solutions but nothing, so had to post here.

Community Member

Same! This is incredibly frustrating.

Community Member

The same happens to me. The app version is Windows 10 (v 2004). Infinite loading. 

Community Member

same with mine.. tried uninstalling and re-installing for 3 times already.

Community Member

Yeah, that doesn't help. Windows troubleshooting doesn't help either.
Community Member

Same problem for me with - just spins, won't open.

Community Member



The same problem for me, it is stuck on splash screen

Community Member

Same here. Please fix this issue now. Thanks!

Community Member

Same issue here on Mac.

knowing this, probably is some server side issue

Community Member

Same problem here, it suddenly can't loaded properly and keep loading.

It happen on my computer with dual OS, Win 10 Pro and Win 7 Ultimate.


Loading on Win 7 Ultimate 64BitsLoading on Win 7 Ultimate 64BitsLoading on Win 10 Pro 64BitsLoading on Win 10 Pro 64Bits

Same here...

Community Member

Hello All,


Our engineers are aware of the issues many of you are currently experiencing with the Upwork Desktop App. They are currently investigating it and will address these issues as a priority. 


We appreciate your patience while we're getting this fixed.

~ Valeria


the Upwork Desktop App does not load anymore. I did the update yesterday, it worked, today it doesnt. It stays with the "loading icon" (see picture)


What do I do? Uninstall and reinstall does not work.


I need to work so it would be good to hear from you fast.





I'm having some issues with your desktop app for windows 10 version 2004, since this morning the app stock at loading and nothing happens, and it is stuck for about more than an hour as you can see on the screen capture.


Could you please assist me to solve this issue?



Yeah, me too.

Impossible to work today 😞

Same thing happened to me today after upgrading to windows 2004, i uninstall and tried to reinstall the app but it just doesn't load

I can't log in via the desktop app, as it is stuck at loading. My google login is already disabled as I always logged in with email/password.


I could use the app fine 5 hours ago.

I was asked to update the desktop app for Mac today, and now when I try to open the app it just keeps on loading forever. I tried uninstalling and reinstalling the app but the issue remains. Anyone else with the same issue?

The same problem.

Desktop App not working on Windows 10 - 1909

Can you make a backup Time Tracker online?

That would be nice!

same, cannot work today!

For me, the same, app was broken 1h ago

any updates from @Upwork team?

Not sure what location this should be posted.

Community Member

And now I tried to download V.5.4.71 and it is not working either...

stays loading forever.

The app just keeps spinning in macOS Catalina!
Please help!!
I have work to do!!!

Same thing here... I'm waiting for the fix but my shift is not finished, so it is URGENT.

Same problem on Windows

Community Member

Same problem with on Windows

Community Member

Can you guys try to contact the support? I did it but Agent Fred said he would connect me to freelancer support and I'm hanging on chat for about 10 minutes without any response.

I have downloaded the UpWork desktop app on my computer. It has me agree to the terms and when I click "accept" it looks like its launching the app. The only problem is, it stays on the "Loading Upwork v." screen and I get the spinning wheel of doom FOREVER. It never moves past this step. I have tried force stopping, I have tried restarting my computer, I have tried uninstalling and reinstalling many times (and yes, I deleted ALL UpWork related things on my computer first). 

I need help! I have a newer Mac and just downloaded the most recent system update. 

Same issue on a Linux machine.
Logs state issues with the files hosted on AWS for Upwork.
Example is:

Thank you for your response! I am unfamiliar with what that means.

I don't think I posted my issue in the correct group! Sorry!

It seems the problems has been fixed by Upwork.

I confirmed that now I can open the Upwork Desktop App. normally on Win 10 Pro and Win 7 Ultimate.


Works for me!

Latest Articles
Top Upvoted Members