» Forums » Freelancers » Re: Time tracker v5.4.71
Page options
Community Member

Upwork desktop app issue when starting

Hi, im trying to start the desktop app but the app just stays loading, i tried uninstalling it, but i think there still some data to delete somewhere. tried open as admin and the same result.


some idea?


current version installed: v.5.4.71



EDIT: the app starts but nothing else happens just keep loading.

Community Member

Hi All,


We'd like to confirm that the issue has been resolved. To launch the App, you may need to  shut it down or "kill" it via system tools. On Mac it can be done via Activity Monitor utility. On Windows you will need to open Task Manager, find Upwork under Processes tab, select, click End task.

~ Valeria

View solution in original post

102 REPLIES 102



Upwork desktop App is stuck at loading screen, I tried reinstalling but facing the same Issue. It says loading and keeps on loading what should I do?



Community Member

me too!

I am facing same issue

I got stuck here(attached screenshot). I opened a case that is still open for the past 48 hours. I tied some troubleshooting like changing updating multiple times, restart the system, opened as administrator, disabled antivirus, change of devices as well as the internet but no solution yet. currently having an hourly contract and the client is refusing to add manual hours

Hi Malik,


I've escalated your concern to th team. One of our agents will reach out and assist you directly via a support ticket.

~ Joanne

Hi Bojan, I followed your instructions and disabled the Google Sign-in but the time tracker is frozen on my desktop. What other troubleshooting can you recommend?

My Upwork Desktop client on Windows 10 environment is not working. It prompted me that a new update was ready. I pressed the later button. Later one I closed the UpWork Desktop app and relaunched it in the hope that it will update and relaunch the app. It keeps on the loading screen saying Load Upwork v. and never finishes loading the app. I uninstalled the app and reinstalled but still the same issue persists. Even tried restarting my machine and tried 64 and 32 bit versions but it stays on the loading screen

I'm facing the same issue at my desktop app.

Upwork desktop app not working please help???

I sure hope they manage to fix this today,

Hello. I try to open my desktop app, but it just does not start, it shows me, that it is always loading, but I can not open it. I tried to reinstall it, but it did not help. Could you please help me?

I have attached screenshot of my screen. 


BR, Pavel


This is happening to me as well, starting at about 1:30 pm today. Something came up that said something about a new UTI (can't remember if that acronym is exactly right) and then it stopped working. Every time I open it, it just gets stuck on the loading screen. I've tried uninstalling and reinstalling as well as restarting my computer (and uninstalling and reinstalling again).

This worked for me, run this from your command line:

mv ~/Library/Application\ Support/Upwork{,.bak}

Got the same thing. It says UTC update then it stopped working.

Hi There,
I can't track my time due to a stuck at loading Upwork V5.4.5.1 help!

My tracker app will not update and open. I clicked to update but have been sitting here watching the thing spin and spin, it never updates and will not open. Not even after uninstalling and reinstalling it. I need to get to work!

I have the same issue

Same here.

same here.

Incident Status

Partial Service Disruption


Team App and Work Diaries



October 5, 2020 10:17AM PDT
[Investigating] Some of you might be experiencing errors on our "Team App" or "Work Diaries". We are aware of the problem and are actively working on resolution. Your patience is appreciated.

Hello, My upwork tracker is not working, it's just on the loading screen. I have tried to restart my laptop, uninstalled and reinstalled a few times but no success. It will only stay on the loading screen.

Please help? 

Seems like an issue on the servers, they are currently working on that



Same here, I installed updated today and it stands forever on loading Upwork 5.x.x. version and I also tried reinstalling/restarting / I tried also installing older version....

Windows PC

Windows 10



The app started fine earlier today.


Sine I re-invoked it a few of minutes ago, the "Loading Upwork V 5.4.71" window has stayed on my screen.

The app is not working on 


1. Windows

2. Mac 


Stuck at loading screen 

Also broken on ubuntu. Not enjoying being unable to track time at all. Having your tracker require something on the home end to even load when it's supposed to be able to track time when 100% offline is very very bad.


Appears to be working now, thanks upwork.

Same problem with UpWork but on Windows 7 64 bits, I tried both version, standard and beta and both are frozen on splash loading screen. Logs attached here.

I have not installed any older version. I installed and reinstalled. I deleted the files from User/AppData after each uninstall.


After update app isn't working at all. 

I only see this loading screen and thats it. 


I have several contracts ongiong and I cannot say my clients "I cannot work cause I cannot bill the time because of app."


What should I do? Alredy re-installed it, doesn't help. Cannot reach the troubleshooting page because it's doesn't work too. I just get back to the main page everytime.


Please help, I must work today. 



Community Member

Having the same problem with

Community Member

Same issue here. I opened a support chat, but they didn't know how to solve the problem. They said they'd escalate my ticket and email me when they have an update. 

Community Member

I am experiencing that as well. Is there a way to rollback to the previous version of the app that worked just fine?

Community Member

Same here, its been on the loading screen for a few minutes now

Community Member

Same here.

Community Member

Dead on Windows 10 and linux. Can't track time offline or at all.

It seems that it is back again. Kill your app and retry.

Yes, its back

Community Member

Hi All,


We'd like to confirm that the issue has been resolved. To launch the App, you may need to  shut it down or "kill" it via system tools. On Mac it can be done via Activity Monitor utility. On Windows you will need to open Task Manager, find Upwork under Processes tab, select, click End task.

~ Valeria

Can we just uninstall and install again?

It has not been resolved.

Hi Natacha,


I'm sorry that the issue persisted even after you followed the steps on how to fix it. I can see that you have already submitted a support ticket to our team reporting that the issue has occurred again. One of our agents will update you directly to assist further. 

~ Joanne
Latest Articles
Top Upvoted Members