🐈 Community
richard_wein
Member

Upwork's disabling of pinch-and-zoom is spreading!

Hi. A few months ago, when the new forum software was introduced, I complained about the fact that Upwork had disabled the standard pinch-and-zoom feature for mobile devices, contrary to their stated objective of making the site more mobile-friendly. My complaints were to no avail, and the forum site has remained that way to this day. That was bad enough, but now they've disabled pinch-and-zoom on the main Upwork site too. Aarrgh!!

 

Please, Upwork, don't do this. It's contrary to good web design practice, and it's particularly frustrating for people like me with older eyes, who regularly need to zoom when using a tablet. For more info please see http://adrianroselli.com/2015/10/dont-disable-zoom.html

 

It's true that this practice is commonplace. It seems to me that nearly 50% of websites do it. In some cases they at least have the excuse that their site doesn't work well when it's zoomed. (Not that this is a very good excuse; they should have designed their site to support zooming.) Upwork doesn't have this excuse. Their site works perfectly well when it's zoomed...if you can get it to zoom.

 

You may be wondering what I'm talking about if pinch-and-zoom is working perfectly well on your device. You may be using a browser/device combination which ignores the "don't allow zoom" setting of the web page. Unfortunately, I've yet to find a browser that will do that on my iOS 9 iPad. (If you know one, please tell me.)

 

Now for the technical bit...

 

In the forum site, Upwork has explicitly disabled zooming with this HTML code:

<meta content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" name="viewport"/>

Note: "user-scalable=no".

 

In the main site, though, they have this meta tag instead:

<meta name="viewport" content="width=device-width, initial-scale=1">

As far as I'm aware, this should not disable zooming. Yet zooming is disabled on my device. So I'm not clear what's going on there. Perhaps a webdev expert could enlighten me (and Upwork).

 

By the way, I know there are some ways to get around the disabling of zoom. But none of them is as convenient as having the website coded properly in the first place.

3 REPLIES 3
petra_r
Member

It still piches and zooms cheerfully on my iPad and my iPhone...

 

Do I recall correctly that you don't have the latest version of the iOS? (You confirmed in your post and I missed it)

 

Have you tried using the desktop version of the site on the iPad?

 

 


@Petra R wrote:

 

 

Have you tried using the desktop version of the site on the iPad?


Hi Petra. I always use the desktop site.

 

There's a further complication, that it's not just a matter of which site you're browsing but also which type of user agent you're browsing as. The Chrome browser (also on iOS 9) has a "Request Desktop Site" option which is available even if I'm already viewing the desktop site. Selecting it switches me from the mobile user agent to the desktop user agent, and that DOES enable zooming on the main Upwork site, but not on the forum site. However, even on the main site it's not ideal, as I would have to keep selecting this option every time I open a new tab (and I like to open most pages in new tabs).

Ask for a new(er) iPad for Christmas 🙂

 

 

Learning Paths