Reply
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

identity verification video call not working

Active Member
Robbie C Member Since: Feb 17, 2017
1 of 34

Hi.

 

My name is Robbie Cruse.

 

I have got identity verification video call request and I click the link I received.

But the link doesn't work. It always goes to homepage of support center.

Can you fix this asap?

 

Thanks.

Ace Contributor
Debmallya B Member Since: Nov 29, 2015
2 of 34

In the Help Center page, go down there should be green button to Verify you profile

Active Member
Robbie C Member Since: Feb 17, 2017
3 of 34

There is only 'Login' button. If I click this, it goes to my upwork dashboard page.

I can't find 'verify profile' button.

Moderator
Vladimir G Moderator Member Since: Oct 31, 2014
4 of 34

Hi Robbie,

 

Please make sure you log into your account before following the steps and initiating the video call.

Active Member
Robbie C Member Since: Feb 17, 2017
5 of 34

Hi Valdimir.

 

Thanks for the answer.

 

I logged into my account and clicked video call link in my dashboard page.

But it goes to home page of help center. And it displays as I did not logged in, although I logged in.

 

Regards.

Moderator
Vladimir G Moderator Member Since: Oct 31, 2014
6 of 34

Hi Robbie,

 

Could you please refresh the page and also try clicking the log in button on the Help Center page?

Active Member
Robbie C Member Since: Feb 17, 2017
7 of 34

Hi Vladimir.

 

Yes, I tried what you said.

 

I refresh help center page and clicked login button, then it goes to my upwork home page.

Url is weird.

https://www.upwork.com/ab/find-work/?kind=error&message=Invalid%20data%20from%20remote%20sign-in%20m....

 

Thanks.

Active Member
Robbie C Member Since: Feb 17, 2017
8 of 34

Hi Vladimir.

 

Even when I am going to visit Help and Support Page by clicking Help and Support under question mark menu, it redirects to https://www.upwork.com/ab/find-work/?kind=error&message=Invalid%20data%20from%20remote%20sign-in%20m....

 

I appreciate if you fix this problem for me.

 

Thanks.

Moderator
Vladimir G Moderator Member Since: Oct 31, 2014
BEST ANSWER
9 of 34

Hi Robbie,

 

Could you please try accessing the Help Center page again and let me know if you're able to see and use the button as explained in the notification?

Active Member
Robbie C Member Since: Feb 17, 2017
10 of 34

It worked fine. It passed all processes successfully.

 

Thanks for your help, Vladimir.

TOP SOLUTION AUTHORS
TOP KUDOED MEMBERS