Reply
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

macOS screenshots not working right with Upwork app after recent update, macOS Mojave and Catalina

Active Member
Andrew B Member Since: Dec 22, 2017
1 of 111

Since the last Upwork app update, maybe a week or so ago, the Upwork app is only capturing blank blue screens, or a blank blue macOS desktop, menu bar, and the upwork app window itself -- but nothing else.

 

The Upwork app prompted me to enable it for "Screen Recording" in system settings, which I did, but it still doesn't work.  

 

Obviously the clients dislike this.

 

I've rebooted, uninstalled and reinstalled Upwork, and tried on both my Catalina MBP and my Mojave iMac and the result is the same.

 

Anyone else seeing this?

 

Any ideas for how to fix?

 

Thanks!

Andrew

Community Guru
Rene K Member Since: Jul 10, 2014
2 of 111

Also since the last update, it freezes on startup almost all the time. I think this update sucks. I've sent a bug report and got crickets.

 

 

 

 

-----------
"Where darkness shines like dazzling light"   —William Ashbless
Active Member
Andrew B Member Since: Dec 22, 2017
3 of 111

I haven't seen the freezing issue, for whatever reason.

Moderator
Bojan S Moderator Member Since: Mar 9, 2018
4 of 111

Hi Andrew,

 

We apologize for the inconvenience this caused you. This is a known issue and our engineers are looking into it. I've escalated your report and our team will keep you updated regarding this issue directly via your existing support ticket.

 

We appreciate your patience while our team is working on fixing this issue.

~ Bojan
Untitled
Community Guru
Rene K Member Since: Jul 10, 2014
5 of 111

Means no more hourly payment protection for Mac users...

 

 

-----------
"Where darkness shines like dazzling light"   —William Ashbless
Moderator
Bojan S Moderator Member Since: Mar 9, 2018
6 of 111

Hi Andrew and Rene,

Could you please download this beta version of the app which includes a build that should resolve the issue? Also, please check these articles for mac's Security & Privacy settings:

How to Allow WebCam and Microphone with macOS Mojave
Enabling Screen Recording Permission on macOS Catalina

We hope this will help.

Thank you!

~ Bojan
Untitled
Active Member
Edwin Marcelo V Member Since: Oct 7, 2019
7 of 111

Not working, I already tried installing the beta and setting all permissions

Moderator
Bojan S Moderator Member Since: Mar 9, 2018
8 of 111

I'm sorry to hear that issue persists, Edwin Marcelo!

 

I will go ahead and follow up your concern with our team so that they can get back to you once they have more information. 

 

Thank you for your patience! 

~ Bojan
Untitled
Active Member
Brylle S Member Since: Oct 16, 2019
9 of 111

Having the same issue. The latest update and beta doesn't work.
It won't even allow you to change privacy permissions; the checkmark on privacy settings doesn't respond. It's checked but can't be unchecked, yet doesn't make proper screenhots anyway. It can only make screenhots of the desktop wallpaper and Upwork app's screen and navigation icon..

It's also annoying that the update is mandatory when it's not working.

As a workaround, I keep the version 5.2.3.771 and refuse version 5.3.3.800:
1. Open Upwork app version 5.2.3.771


If it got update for 5.3.3.800:
2. Go to "/Users/<Your User>/Library/Application Support/Upwork/Upwork/Updates/5.3.3.800"
3. Delete that update
4. Click Upwork's "Update Now" button. It will only keep the spinning turning because the update got deleted.
5. Quit Upwork app then open again.

 

Screen Shot 2019-10-16 at 5.26.07 PM.pngScreen Shot 2019-10-16 at 5.43.57 PM.png

Moderator
Valeria K Moderator Member Since: Mar 6, 2014
BEST ANSWER
10 of 111

Hi Brylle and others,

 

I'd like to follow up here to clarify the issues that you and others have reported on this thread as well as fixes and workarounds we've been able to provide.

 

  •  The issue with screenshots has been fixed on the most recent version of Upwork Desktop App. It can be downloaded via this link.
  • Some of you may still run into issues with being unable to uncheck the security option for screen capture. That is due to a known issue with Catalina OS that affects multiple apps not just Upwork Desktop App. The solution is to run `tccutil reset All` in Terminal app to force reset all permissions so that they are properly requested again.

 

Please, refer to Vladimir's post from earlier for more detailed instructions and screenshots:

 


Vladimir G. wrote:

1. Close the Desktop App

2. Run tccutil reset All com.upwork.Upwork in terminal to reset any granted permissions.

            2.1. If "Upwork" STILL is present in the Screen Recording section of Settings & Privacy, then please use tccutil reset All

 

3. Install the Upwork Desktop app version from this link.

4. Test functionality by taking a screenshot with the App (unless customized should be prompted by Ctrl+Alt+S or Ctrl+Alt+A, check the Keyboard Shortcuts in Settings to confirm this option is turned on) and authorize Upwork App when seeing this pop-up.

 

This is how the pop-up and your Security settings should look like after following the steps above:

 

1. Select "Open System Preferences".

UDA1.png

 

 

 

 

 

 

 

 

2. Tick the box next to "Upwork".

UDA2.png

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. Select "Quit Now"

UDA3.png

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4. Confirm "Upwork" is on the list as shown below.

UDA4.png

 

 

 

 

 

 

 

 

 

 

 

 


 

~ Valeria
Untitled
TOP SOLUTION AUTHORS
TOP KUDOED MEMBERS