cancel
Showing results for 
Search instead for 
Did you mean: 

"U.S. only" in job feed - how to get rid of it?

leeannmerrill
Community Leader

somehow "U.S. only" showed up in my job feed.  I don't know how to get rid of it, and every time I do a search it's showing U.S. only jobs.  If I turn it off, it turns itself back on (times a million...then I saw it in my job feed).  Does anyone know to make it go away?

16 REPLIES 16
mtngigi
Community Guru

There's no need to post the same question twice.

 

Re job feed - you don't have to click on the "USA only" icon - it's there for those who want to search using that parameter. Your regular job feed is still there.

sorry, posting twice was an accident.  I did not show post going thru first time.

 

I know I don't have to click the U.S. only.  What I'm saying is - even if I don't click (i.e. activate) it, it shows up as a filter in any job search I do, per below, and if I turn it off it turns back on immediately.

 

I'm not having that issue - I have about 7 different job searches saved, and they are all showing up.

 

Do you have saved job searched in your feed?

I know that doesn't solve your issue: but non-US freelancers are getting job recommendations that include US-only jobs that they then cannot access & apply to.

 

Meaning: your job pool is a lot bigger than that of non-US residents - that is, unless you're ONLY shown US-only jobs. 

Hi Ela,

 

The issue with US-only jobs showing in the recommended jobs email has been brought up earlier today and we're making sure the issue is being worked on.

 

Sorry about the inconvenience.

~ Valeria
Upwork

I am only shown U.S. jobs - that's the problem.  And when I "turn off" the filter it pops right back up.

Yes, several of us have reported the "stuck on US" glitch. If you turn it off and refresh or click on a job and go back, the filter again defaults to US only. OP, you can save jobs that you are interested in (while doing your search with US jobs option off). Then go look at them individually in your saved jobs file. Otherwise, I think it is a known glitch waiting for a fix. 

groovy, thanks for the update!

Lee Ann,

 

At this time there isn’t a way to change the default. This toggle is a new feature, designed to make the location filter easier to find and to turn on and off. We welcome feedback on this new design, and I’ll be sure to relay your comments to the team.

~ Valeria
Upwork

I have the "stuck on US" glitch. It's annoying. I can't change it back. It was fine the way it was before.

US-only search ignores UK clients. Some of my best clients come from the UK.

Did you recently apply to a U.S. only job?  I did just to tick the box.  Seems like that's when it started but I can't be sure.

aocumen
Moderator
Moderator

Hi everyone, 


As Tonya has shared, this has already been reported to the team and they are still investigating the issue. We'll update everyone if the team has more information, or if the issue has been resolved.


~ Avery
Upwork

It's not just that it turns itself back on.  I don't see how to turn it off in the first place.  I thought there was a way to do that, but now I can't find it.

 

Hi Catriona,

When you do a search and click on the search button, you should then see the toggle show and you can toggle it off and save your searches without the U.S filter applied.954410075706355712.png

~Nina

When I do a search, I do it by skill-set in the advanced search. Every search includes US-Only as a filter, so I click on the X for that filter, and I can see the rest. Today I did a search, clicked off the US-Only filter, and saved the search.

 

Now, step one in searching for jobs is to open the saved search (US Only No, Expert, Five or Fewer responses, Payment Verified). I then use a different skill-set from the menu.

 

We'll see if the workaround succeeds.

Had come around to that fix myself.  I think it's the best we can do.

TOP SOLUTION AUTHORS
TOP KUDOED MEMBERS