walkerrowe
Member

upwork on Ubuntu: an unknow error has occurred

Is anyone using the time tracker on Ubuntu 14.04.  I tried the deb standard and deb beta and both do not connect.  They say "an unknown errhas occured."

51 REPLIES 51

Hi Hiral,

 

You can find the solution to this problem on the second page of this thread and in the last comment here.

Untitled
iaroslavr
Member

Ubuntu 14.04 64bit

I confirm ssl connection bug, Dmitry's workaround working for me too

vnem
Member

Thanks, everybody! The downgrade in this thread worked for me.

 

I'll just add how the bug behaved for me to help you diagnose more people.

 

Upwork persistently ran in time-caching mode. Had I not chosen to "Clear cache and restart," it would not have shown an error similar to what Walker describes. So any Linux users stuck in time-caching mode could benefit from this thread too.

fdaza
Member

Hello Guys

I have the same issue BUT I am using UBUNTU 12.04 can someone please show me how to downgrade libnss3 to previous working version?

 

thanks alot.

 

Fabricio D.

also guys (from Upwork dev team) is there an ETA on the upwork team app fix?

 

thanks.

 

Fabricio Daza.

pshevtsov
Member

Hello, I fixed the issue with libnss3 versions incompatibility by running Upwork Team App in Docker contatiner. I described it here: https://community.upwork.com/t5/Freelancers/Upwork-Team-App-in-a-Docker-container/m-p/167606

HTH
Cheers

ivan_koptev
Member

Since Ubuntu 16.04 now supports Snap packages format, maybe Upwork team could release a Snap package for Upwork Team App? So at least Ubuntu 16.04 users will have it finally worked.

Because for now, the only working solution for me is running Upwork Team App in Docker container (thanks Petr S for his work).

A lot of devs start using Ubuntu 16.04 LTS.
Please update Tracking tool, so everybody can work normally and do not spend much time looking for solutions how to run it. Deliver please proper service which you are saying you do 😉

ashish_soft
Member

[0606/183732:ERROR:browser_main_loop.cc(173)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki/LinuxSUIDSandboxDevelopment for more information on developing with the sandbox on.
[0606/183732:FATAL:scoped_file.cc(29)] Check failed: 0 == IGNORE_EINTR(close(fd)). : Bad file descriptor
[0606/183734:ERROR:renderer_main.cc(200)] Running without renderer sandbox
[0606/183734:ERROR:browser_gpu_channel_host_factory.cc(134)] Failed to launch GPU process.
[0606/183746:ERROR:renderer_main.cc(200)] Running without renderer sandbox
[0606/183746:ERROR:renderer_main.cc(200)] Running without renderer sandbox
[0606/183746:WARNING:nss_ssl_util.cc(370)] Unknown SSL error -12218 (SSL_ERROR_ENCRYPTION_FAILURE) mapped to net::ERR_SSL_PROTOCOL_ERROR
[0606/183746:WARNING:channel.cc(549)] Failed to send message to ack remove remote endpoint (local ID 2147483648, remote ID 2)
[0606/183750:WARNING:nss_ssl_util.cc(370)] Unknown SSL error -12218 (SSL_ERROR_ENCRYPTION_FAILURE) mapped to net::ERR_SSL_PROTOCOL_ERROR

bavovna
Member

This is my second post in this thread.

 

On xUbuntu 14.04 32-bit I could get the app working by downgrading libnss, as explained on Page 2 of this discussion.

sudo apt-get install libnss3=2:3.15.4-1ubuntu7 libnss3-nssdb=2:3.15.4-1ubuntu7 libnss3-1d=2:3.15.4-1ubuntu7

Recently I installed Lubuntu 16.04 64-bit and could not find older libnss to downgrade to, so I decided to try Upwork's workaround described on this page again, which, btw, did not work for me before.

You can read their recommendations, follow them, see that they don't help and then do the following.

1. download older libnss (they give you links to 32-bit and 64-bit versions on that page), 

2. unpack downloaded .deb file with your archive manager.

3. find x86_64-linux-gnu folder inside data.tar.xz -> usr/lib 

4. create ~/libnss (or choose some other name) and copy x86_64-linux-gnu folder there.

5. Move all files from ~/libnss/x86_64-linux-gnu/nss to ~/libnss/x86_64-linux-gnu so that all files are in one folder

In my case I named the folder ~/libnss/test2
folder structure

6. export LD_LIBRARY_PATH=~/libnss/x86_64-linux-gnu

7. nohup upwork &

 

Now it should work.

In my case it did not work unless I moved all files from nss subdirectory to its parent directory. That was the trick.

 

Upwork says you should run steps 6 and 7 every time you need to start the app, but you can create a shell script to avoid that.

Create a file ~/.Upwork/start-with-old-libnss.sh
Add those commands from steps 6 and 7 to that file:

#!/bin/bash

export LD_LIBRARY_PATH=~/libnss/x86_64-linux-gnu
nohup upwork &

Then make the script file executable and create a link from Desktop to that script file.

chmod +x ~/.Upwork/start-with-old-libnss.sh
ln -s ~/.Upwork/start-with-old-libnss.sh ~/Desktop/Upwork


Now you should be able to start upwork app by clicking the icon on your desktop.

Upwork start script and its link

holms
Member

In debian jessie 64bit, I've just found older version with `apt-cache policy libnss3` command, and installed older version, and upwork launched fine. devs need to fix it, i've send a request, and even contacted support in chat... they said they'll connect to tehnical engineer

vladag
Community Manager
Community Manager

Hi all,

 

Our team implemented a solution in the latest Team app update (4.2.58.0 version and later) that resolved the problem Linux users were experiencing with the libnss3 library. We're working on updating the standard 4.1. version of the Team app as well, but in the meantime you can download the latest beta version from the drop-down menu here.

Untitled