» Support » Known Issues and Workarounds » Desktop App: Checking if the site connection ...
Page options

Desktop App: Checking if the site connection is secure

Some users may experience issues with the Desktop App.


Error message: "Checking if the site connection is secure"


Screenshot of the issue: 



Our engineers are investigating this issue and we'll update this thread once we have more information.

UPDATE as of June 1, 2023

Hi everyone, 

Thank you for patiently waiting. Because this particular issue is related to Cloudflare, it is beyond our control to directly fix or improve it. There can be various reasons for Cloudflare errors, including problems with domain reputation and blocked or underperforming IP addresses. These factors can result in errors when your app connects to the server. 


As a workaround, our engineers recommend checking the status of your IP address using this website: https://talosintelligence.com/reputation_centerIf the result indicates a poor IP reputation, we recommend contacting your ISP (Internet Service Provider) to request another IP address or check how the reputation can be improved. If you have a backup ISP, try switching to that network.

If you continue experiencing issues, we recommend contacting your Internet Service Provider to address this matter effectively, as they are best equipped to handle and resolve this issue.


Community Member


I'm having an issue with the time tracker. It keeps bringing the prompt "Checking if the site connection is secure,upwork needs to review the security of your connection before proceeding."


I've already uninstalled my old tracker and installed a new one but with no success.


I have an hourly contract and need to get the tracker ASAP. So, I would appreciate your help!



Hi Marie,


Thank you for reaching out. I can see that you've already raised a support ticket regarding your concern. You can access your support tickets here. Note that support requests are responded to in the order they are received. Kindly allow 24-48 hours for the team to follow up with you and assist you further.


Community Member

Hi Andrea,

I also has this issue when opening upwork site and opening the time tracker app.

I'm using time tracker version on MacOS 13.2.1


Hi Ade,


Thank you for reaching out to us. I shared your report with our team and one of our agents will reach out to you using a support ticket to assist you further. You can access your support tickets here.


Community Member



I'm having a connection loss problem. My internet connection is stable, but the problem still persists. I already tried signing out/signing in, restarting my pc, and uninstalling / re-installing the time tracker but still not solved.




Please help 



Community Member

Hi please help my time tracker said it's "Connection Lost" though my internet connection is working fine.

Community Member

'Hi Please Help Me!! My tracker states as "Connection Loss" but my internet is stable. Please, I have project to be done. and its needed to be recorded as my client requirement.



Community Member

I have an issue with my desktop app. I worked for about 1 hour, the app was taking screenshots but not updating the time. Issue persisted and I was unable to work any further. I have installed the app afresh but am receiving the message "Checking if the site connection is secure" . Kindly Assist.

Community Member
Go to setting, click ond privacy and security, from there click in allow
pop up on this site then check back to know whether it has start working
Community Member

Hi Andrea

I'm having an issue with the Desxtop App. It keeps bringing the prompt "Checking if the site connection is secure,upwork needs to review the security of your connection before proceeding." And the app is not working!

Then I have uninstalled my desktop app and then I go to https://www.upwork.com/ab/downloads?source=Footer to download the latest app but there was no option to select version and then the download web page goes to 404 error. After then I go to https://support.upwork.com/ to get support through contact. Then I select on "Apps" and the page opened, but within a second the page redirect to home page again and I was not able to contact with support team. And finially I tried to install old desktop app but I face the same problem.

I am so much worried, Please do a solution for it.

Warm regards,