» Support » Known Issues and Workarounds » Desktop App: Checking if the site connection ...
Page options

Desktop App: Checking if the site connection is secure

Some users may experience issues with the Desktop App.


Error message: "Checking if the site connection is secure"


Screenshot of the issue: 



Our engineers are investigating this issue and we'll update this thread once we have more information.

UPDATE as of June 1, 2023

Hi everyone, 

Thank you for patiently waiting. Because this particular issue is related to Cloudflare, it is beyond our control to directly fix or improve it. There can be various reasons for Cloudflare errors, including problems with domain reputation and blocked or underperforming IP addresses. These factors can result in errors when your app connects to the server. 


As a workaround, our engineers recommend checking the status of your IP address using this website: https://talosintelligence.com/reputation_centerIf the result indicates a poor IP reputation, we recommend contacting your ISP (Internet Service Provider) to request another IP address or check how the reputation can be improved. If you have a backup ISP, try switching to that network.

If you continue experiencing issues, we recommend contacting your Internet Service Provider to address this matter effectively, as they are best equipped to handle and resolve this issue.


Community Member

Hello, i had a weird issue with the tracker today... I started working today and notice after of 3 hours of working that my tracker was not tracking the screen, so i tried to add time manually.. and only had the option to add time for the sunday.. not today (Monday).. do I restarted the app and it start counting the time and taking screenshots.. but the worked time was not tracked... so i decided to uninstall and download the tracker again.. now it's stuck in checking if the site connection is secured.. before uninstall i removed cache and restarted the app.. 
how can i solve this issue? 

Community Member

Please, I need some help with this, already deinstalled and installed the app again, i'm not getting any different.. also tried to contact with customer service but the contact button doesn't work 


Hi Alvaro,


Thank you for reaching out and reporting this here in the Community. We weren't able to replicate the issue on our end. If you continue to experience this error, could you please try using a different internet service provider when tracking with the Desktop App?


If the tracker can be successfully enabled using a different internet provider, you will need to reach out to your main connection provider. Let us know if you still need further assistance and we'll look further into that for you.


Community Member

Thanks that did the trick 🤗

Community Member


I'm also having an issue with the time tracker. It keeps bringing the prompt "Checking if the site connection is secure; www.upwork.com needs to review the security of your connection before proceeding."


I've already installed a new tracker but with no success.


Already many are facing the same issue. How long will it take to investigate this issue by engineers so that we can get some quick updates?


I have an hourly contract and need to get the tracker ASAP. So, I would appreciate your help!


Community Member

Hey Re: Tracker get stuck in checking if the site connection is secured 
I have 1:1 the exact same problem starting 2 days ago.

What exactly should I understand by this: "You will need to reach out to your main connection provider."

I can't just suddenly change my internet provider.

Can you tell me step by step, what you did?


Hi Michelle,


If you have a different internet connection you can try, like your phone's hotspot, that would help isolate the issue and determine if there's an issue with your main internet provider. Otherwise, would you please try uninstalling and reinstalling the application and see if that helps? Don't hesitate to reach out if you need further assistance.

Community Member

Hello Support,


I am getting such problems frequently—three times in the last 1 month. Time tracking is taking pictures, but work daily photos are not added. Please solve my problem. 



Community Member

Same problem! My time tracking not working. I can't see new ticket

Community Member



I can't access this site. what should I do? Please help me.