» Support » Known Issues and Workarounds » Desktop App shows 'Checking connection. Faile...
Page options

Desktop App shows 'Checking connection. Failed to fetch.'

Hi Valued members, 


Some users may experience issues having an error with the Desktop App. Please see this attached screenshot for your reference:




Our engineers are looking into these errors and working to address the issue that's causing them. We'll keep this thread updated with more information or if it's been resolved.


Edited to add information. 


Hi everyone, 

Thank you for your patience while we investigated your issue with the Upwork Time Tracker.


We are aware that some customers using Windows 7 have been unable to use the Upwork Time Tracker app and that some customers who enable TLS 1.2 on their local system are able to resolve the issue.

Please note that the Upwork Time Tracker App is compatible with the following Operating Systems:


  • Windows 11 64-bit
  • Windows 10 64-bit
  • macOS 13 Ventura
  • Ubuntu 22.04 LTS 64 bit


For the best experience, we recommend using the app with one of these Operating Systems. Although the app may work with other versions, we don’t officially support them, which means that we are limited in the troubleshooting and resolutions we can provide.


If you are using a compatible Operating System and still having issues with the Time Tracker, please reply and let us know what version you are using and (if not previously provided) what you’re currently experiencing when trying to use the app.

Community Member
Retrying Please try restarting your app. If the issue persists, contact customer support and provid

I am having trouble with time tracker login. It's say


Please try restarting your app.

If the issue persists, contact customer support and provide a copy of the error below.


Query: app.js

Status: 0

Trace ID: Failed to fetch

See https://status.upwork.com for updates.



Community Member

Its been a while i have been trying to install upwork desktop app but after being installation, an error keeps coming up. like query: app js.

I tried uninstalling and installing all the version available to download but it is not working.

It was working fine before when i cleared all the programs from my computer but now it is not working and my client wants me to work with Upwork time tracker. Kindly look into the matter.

My work has been on hold. 

or anyone if ya know how to fix this, let me know!

Community Member

Hey! I have raised an issue too regarding the same problem with Upwork time tracker app. Please solve this asap! 

I am unable to work. I can't even update my window 7. Lack of storage in the computer. It was working fine before on window 7 and all of a sudden, i get this problem.

Very annoying.

Community Member

I have downloaded the Upwork desktop app but it just says "We can't complete your request right now"  and shows the following error: 

Query: app.js

Status: 0

Trace ID: Failed to fetch


I have tried and failed to launch each of the four versions of the app available here: https://www.upwork.com/ab/downloads?source=Footer.


I'm running Windows 7 Ultimate (64-bit). Can anyone look into the issue? 


Community Member

I submitted a ticket earlier, but the response email directed me to this forum without providing a solution. Unfortunately, I still find myself facing the same problem. I currently use Windows 7, and it seems that the desktop application isn't compatible with this operating system. Could you please elaborate on this? WhatsApp Image 2023-08-16 at 12.45.43 PM.jpeg

Community Member

We can't complete your request right now.

Please try restarting your app.

If the issue persists, contact customer support and provide a copy of the error below..




Community Member



I am opening my desktop app and it says 

'Query: app.js

Status: 0

Trace ID: Failed to fetch".



What could be the problem?


Thank you.