» Support » Known Issues and Workarounds » Issue with accessing profile. Error: "We'll b...
Page options

Issue with accessing profile. Error: "We'll be right back" and "Sorry, we can't let you in"

Some users experience issues with accessing their accounts. 


Screenshot of error: 




We would like to let you know that our engineers are aware of this issue and they are working as fast as possible to resolve it. We will update this thread as soon as we have more information. 


Edited to update information. 


We would like to let you know that this issue should now be resolved. Please try again and let us know if the issue persists. 


Thank you. 

Community Member

Same thing for me.

Community Member



Is there anyone who can help me with this? I'm just scrolling down looking for an updated job posting however in a minute I redirect into this, I cannot enter my account or they would not let me in.



Community Member

I've gotten this too. Does anyone know if the issue has been reported to Upwork or gotten any updates from them? I tried to report it, but that's also down for me. 

Community Member

Same here, but the UpWork Status link says everything is online. Hopefully, they are already aware of the issue and actively working to address it. Hang in there, everyone!

Community Member

Having the same issue.

Community Member

Same here. It says to check the status at https://status.upwork.com/ which says Upwork is fine with no issues.


Nowhere to report there is an issue bar logging a ticket... which takes days to get a response.


Frustrating as my clients work spreadsheets have been sent via messages on Upwork, so im effectivly sat waiting for Upwork to fix a system they themselves say is fine...... grrrrr. 

Community Member

I can't report it either! Issues have been reported on Down Detector, but Upwork's status site says everything is operational...

Community Member

Sit tight, it's a bug. Same for me. Probably the system has crashed.

Community Member

I am having the same error. 500 A. 

Kindly assist.

Community Member

Same for me. May be they are updating or the server is down.