» Support » Known Issues and Workarounds » Issue with contracts not showing in Desktop A...
Page options

Issue with contracts not showing in Desktop App. Error: Failed to load contract Error 500 (N)

Some users may have experienced issues where their contract was not showing in Desktop App. We would like to clarify that this is a known issue and it should already be resolved on your end. 


Screenshot of the error for reference.




Could you please check and let us know if the issue still persists on your end? We will be sure to assist you further. 


Edited to add. 7/31/2023


We would like to let you know that this issue is now resolved. If the issue persists on your end please let us know and we will assist you accordingly. 

Community Member


 Pls help and in the app it doesnt show up.

Community Member

I have the same issue too. Been trying to open the contract & update my work diary but get the same result. 



Community Member

I am facing the same problem as well. I've been attempting to access the contract and update my work diary, but still can't open my contract. Please helpScreenshot_2.png us. 

Community Member

Hi Upwork Support,

I need urgent help with a contract loading issue on Upwork. Every attempt I make to load a contract results in a failure. I have tried troubleshooting on my own to no avail. Can you please assist me in resolving this problem?

Please see attached photo for reference

Community Member

If you're unable to see your Upwork contract in both the app and web interface, here are a few steps you can take to troubleshoot the issue:

  1. Refresh the page or restart the app: Sometimes, a simple refresh of the page or restarting the app can resolve display issues. Try reloading the web page or closing and reopening the app to see if the contract appears.

  2. Check your filters or search settings: Ensure that you don't have any filters or search settings applied that could be hiding or excluding the contract from your view. Review your filters and search options to make sure they are set correctly.

  3. Clear your cache and cookies: Clearing your browser's cache and cookies can help resolve any temporary issues that may be preventing the contract from displaying. Go to your browser settings, clear the cache and cookies, and then try accessing Upwork again. Website: 36 inch sparklers

Community Member

Hi there,


Can someone help me with Error 500 (N) issue. My logged time was lost, can't access the active contract and the rate per hour change. I can't continue working on the project.


Looking forward to hearing from you.


Thank you.


Hi Panos,


If the contract is active but still unavailable in the app, it most likely recently changed its status. You can force a refresh of your contract list by selecting the refresh icon in the Upwork desktop app. Please see this screenshot for your reference.


Please continue coordinating with the team through the support ticket you've raised here about your concern if you're still experiencing the same error. The team will surely assist you accordingly.



Hi Dear Members,


We saw your posts in the community and shared them with the appropriate team. Rest assured that we'll have your reports reviewed and keep this thread posted with updates from the team. We seek your patience and utmost understanding while sorting this out for you. Thank you!


Community Member

Hi Arjay, I'm also experiencing the same problem. I've tried restarting, refreshing, clearing the cache, removing filters--No matter what I do, I still cannot access my contracts. Seeing as the work week ends tomorrow, I really need some help getting my hours tracked. I cannot even track them manually as it says there's no contract--even though I know there is one. Can you please help? Thank you. 

Community Member

Please guide me to solve this issue, I've done everything I can to solve this problem but all in vein, please help me with this issueWhatsApp Image 2023-07-15 at 8.44.52 AM.jpeg