🐈 Community
» Forums » New to Upwork » Trouble editing profile
Page options
hashim-ikram
Community Member

Trouble editing profile

Hi, I'm having trouble editing my profile. When I go to settings or try to edit my specialised profile, it takes me to a blank page with a loading icon and it says "device authorisation" in the URL but the page never loads.

hashimikram_0-1665904887799.png

 

6 REPLIES 6
759e32fa
Moderator
Moderator

Hi Hashim,

 

I tried but wasn’t able to replicate the issue you’re describing. Could you please try using a different browser or the incognito mode of your current browser? You may also try clearing your browser’s cache and cookies. Also note that we only officially support the latest two versions of Google Chrome, Microsoft Edge, Mozilla Firefox and Apple Safari.


~ AJ
Upwork
nicole_v_
Community Member

It might be because you're not using the latest version of the browser. I noticed that in the corner your browser has an update available. That may be the reason for this. 

hashim-ikram
Community Member

Hi Annie/Nicole,

Browser is updated now and I tried in incognito. The UI seems to have changed a bit but the issue is still the same.

 

hashimikram_0-1666021400059.png

 

williamtcooper
Community Member

Logout, close the browser and reboot your computer. If that doesn't work, contact Upwork's technical support and have an image of the issue ready to send them.

Hi William, 

I've already tried those things. How can I contact technical support?

Hiu Hashim,

 

Thank you for your confirmation and I'm sorry if you're still experiencing this error. I'll have one of the team members assist you further via a support ticket. Kindly expect an update on this page with the ticket once your case is fully reviewed. Thank you!

 

~ Arjay
Upwork
Latest Articles
Upcoming Events
Feb 13
Feb 28
Upwork Community Virtual Hour
Community Hour English
Mar 28
Upwork Virtual Community Hour
Community Hour English
Learning Paths