🐈 Community
» Forums » Support » Static Javascript is not working in Detailed ...
Page options
Community Member

Static Javascript is not working in Detailed Job Description Page/New Tab


I am facing an issue where static javascript is not working for the past 2 days on the Job description page when I opened the job in a new tab.


I have tried Firefox, Chrome, Edge, opera, and in every browser, the static javascript is working for the first time/ a few minutes afterward, I couldn't access any of the javascript be it "save job", "view more" jobs of the current client, "jobs in progress".


I am worried this could be a bigger problem because "view more" is a static javascript that loads after a click but the "save job" feature is "Disabled" after all which makes me feel like someone is blocking my access to Upwork.


I have attached an attachment where "save job" is being disabled.


Can someone in the support team help me overcome this issue? Thank you!


Hi Hari,


Thank you for your message. I'll have one of our customer support agents reach out to you directly and assist you further.


Thank you


Community Member

I am having the same problem... and I can't apply for jobs either. Nothing happens when I click on Apply. 

Me too

Hi Keith,


Thank you for your message. One of our team members will reach out to you via ticket as soon as possible and assist you further.


Thank you.


Community Member

Why this ticket is marked as "Solved" when there is no solution!!


I'm encountering the same problem for three days now and tried switching different browsers with no luck! Javascript is not run correctly, I can't apply, the "Save Job" button is disabled, can't expand the client's "Jobs in progress" section.


Obviously, this is a technical issue related to the website rather than the user account, so I believe reaching out to freelancers personally won't help much but rather forward this ticket to the technical team, or more precisely, your front-end developer(s).




Hi Reda,

Sorry this is my first Post here and yeah the problem is not solved yet and I have been in touch with the support team through mail.


I have received an automated mail from Upwork to choose a solution for my problem and as the issue is being addressed through my in-mail I chose the support team member's reply as a solution.


I am sorry again as I am new to this community. If any support team member can change this to unsolved that would be helpful for the community.



Community Member

No worries @Hari, I apologize if I've been rude!


By my reply, I truly meant it for @Pradeep H, the moderator as this is a critical issue on the website which prevents us from doing any task so they should immediately forward it to the technical department.


I hope they fix this soon.




It's Okay Reda!


Yeah, I too have started to focus on learning stuff rather than applying for any new jobs until this issue is resolved.


I am not sure, If this issue is due to the recent migration of Upwork with a new frontend framework(Vue.Js) because in my mobile application I don't find any problem related to this issue.


I hope they will fix it soon yeah and would like to see some updates here about this issue as Issues are reflected in the Production environment.




I want to save a search after using Advance Search, but it gets stuck as loading after I click it. If I don't use Advance Search than it can get saved right away.

Thank you in advance to whomever might help me out,

Edit: First time posting, no idea how it got posted as a reply. Apologies

Latest Articles
Featured Topics
Learning Paths