» Support » Known Issues and Workarounds » All Job Feed's Updates on Main Page
Page options

All Job Feed's Updates on Main Page

Freelancers and Agencies may not be seeing results when searching for "U.S only" jobs. This issue is also affecting the Most Recent tab. Our engineers are aware that this is happening and they are working on a fix. We'll update all members here as soon as we have more information. Thank you!





**Edited to Update Information** 11/02/2023


All Job Feeds on the main page are impacted by the issue. Our engineers are looking into these errors and working to address the issue that's causing them. We'll keep this thread posted with more information whenever we receive updates from the team.




While we are working on resolving this issue we would like to let you know that you can use the search option to find recent and relevant job posts for you. You can find more information about performing a search in help articles below. 



Thank you for your patience and understanding. 


**Edited to Update Information** 11/16/2023


We would like to let you know that this issue is now resolved. 

Community Member

Hello Upwork, 


This problem just resurfaced today. I have cleared my cache and cookies but it didn't solve the problem.


Job posts on my Recent Job feed drop 20 minutes late. 


Please help!! 



Hi Chijioke,


Thank you for reaching back and reporting this. I've shared your report with the appropriate team for further review. One of the members will reach out with more information and further assistance via a support ticket on this page


Community Member

I've been seeing the same thing today, but for me it's an hour late. It very briefly worked correctly this afternoon (around 1pm CST) but since it has not been updating correctly.

Community Member



The US only search filter isn't working. It comes back with a "no results" message. I tried this on 2 different browsers, and tried it with the only filter that's turned on is US only. Could it be just my account, or is anyone else having an issue with it? 




Community Member

I have checked and my US only search filter is working. 

Community Member

Hello Dave,

I suggest you try clearing your cache, then try again. Also use your mobile app, update it as well and then try again.




Community Member

Thanks for checking. 

Community Member

Likley not a cache problem since I tried it on two different browsers. I'm guessing Upwork has to reset my account. I'll contract support. Thanks! 

Community Member

Alright, you are welcome

Community Manager
Community Manager

Hi David,


Thank you for reaching out to us. I’ve escalated your community post to a support ticket so that we can look into this further and assist you accordingly. One of our agents will be in touch with you soon to assist.