» Support » Known Issues and Workarounds » Issue with adding manual time. Error: "Failed...
Page options

Issue with adding manual time. Error: "Failed to load initial marketplace vendor data."

Some users may experience issues with adding manual time. 


Error message: "Failed to load initial marketplace vendor data."


Screenshot of the error: 



Our engineers are aware of this issue and they are working as fast as possible to resolve it. We will update this thread as soon as we have more information. 


We appreciate your patience.


Edited to add:


Hi All,


This issue is resolved and we will be closing this thread from further comments. However, if you still experience the issue mentioned on this thread please let us know by posting in Community Support section and we will be happy to assist you accordingly.


Thank you.

Community Member

The below isssue coming, when you going to Timesheet and timesheet data is not loading and can't insert the manual time.


"Failed to load initial marketplace vendor data."

Community Member

Me too - happening today but i also got an email to re-verify ID, which is like the third or fourth time Upwork asks me to do in the last few year. Wonder if it's related


Hi Tarun and Georges,


Thank you for reaching out to us and bringing this to our attention. I checked and it looks like you already have a ticket regarding the issue you experience. Please follow up on your tickets and share any additional information you can so that our team can assist yo further. 


Community Member

I have the same problem


Hi Sergey,


We're aware of the issue you raised and are taking it seriously. We’ve escalated your post to a support ticket where one of our agents can assist you further. You may access your ticket and coordinate with the team on this page once your case is fully reviewed.


Community Member

I am seeing the same issue as well.

Community Member

Hi Arjay,


I'm facing the same issue too when tried to add hours on timesheet. I didn't received any email to re-verify. Attached screenshots of message and console errors. 

Community Member

Same. This is even recent topic. Tried using different browser, but still the same issue/error. Clear browser cache didn't work.

Community Member

Also experiencing this issue. Any update on when it will be fixed?

Community Member

me too.. I can't view the timesheet.  Failed to load initial marketplace vendor data