» Forums » Freelancers » Upwork Time Tracker App
Page options
Community Member

Upwork Time Tracker App

We are facing problem while using the desktop 64-bit, 32-bit or even standard version app. The tracking time doesn't show up and we can't access the tracker of different people. When we click to any contract it doesn't allow to access it and start the contact. 


We also tried below options as per your support suggestion. But still we facing same issues.


To resolve this, please consider the following steps:

Option 1 - Please try uninstalling the desktop app. It is important the old version is completely removed from your PC. Then, download the standard version of the Upwork Desktop App and install it: https://www.upwork.com/ab/downloads/. If not resolved, please proceed to Option 2

Option 2 - Look for the desktop app icon from the tray menu (see: https://url.upwork.com/_01Tl0y8BABXDaFuD_8axkkaulBx9mHMLj0) > Right-click on the icon > Open Time tracker (see: https://url.upwork.com/_01Wnj7SF8l8KyfFGLjWn5BAl3KqPpaSQ-Z)

Then retest the desktop app, and you might need to restart PC if needed. 


Please help me to resolve this issues. Our whole work is stuck due to this issue.




Community Manager
Community Manager

Hi Naina,


We’ll have one of our agents reach out to you via a support ticket to assist you with this issue. 


Thank you! 

~ Bojan

Still Waiting for a response.

Hi Naina,


Thank you for your message. I see that the support team has already reached you via a support ticket here. Please don't hesitate to follow up with them on your support ticket if you have additional questions regarding your concern.


Thank you



Still no response in support ticket. I Really Disappointed.

Hi Naina,


I can see you were able to reply to our team's instructions, please know that the team's response time is 24-48 hours. That said, I will go ahead and follow up with them, you should expect an update soon.



Hi Andrea, I understand. But we are facing this problem from many days and not able to work on the clients contract. I hope you also understand my concern. My team members are not able to run the tracker for clients projects on their PC's. 

Community Member

Hi Naina was your issue resolved, Because it happened with too and even after troubleshooting and everything, I am still unable to open the app even after clicking on it. Could you guide how it worked out for you.

Hi Jaspreet,


Thank you for reaching out to us. I checked and it seems that you already created a support ticket for the issue you are experiencing. Please allow more time for our team to review your case and respond accordingly to your ticket. You will be notified of their response.


~ Nikola
Community Member

my upwork app for time tracking doesn't open. i tried everything still not opening. I have to pause my work because of this!

Hi Geronalyn,


Please try the steps in this help article to troubleshoot your Time Tracker App. You may also report your issue by following the steps on 'How do I report a problem? So our team can assist you further. 


~ Joanne

I am having the same issue! I downloaded the newest version, have no other versions lingering anymore anywhere on my PC, and the thing has downloaded but refuses to open.


Hi Charlotte,


Thank you for reaching out. I can see that you've already raised a support ticket regarding your concern. You can access your support tickets here. Note that support requests are responded to in the order they are received. Kindly allow 24-48 hours for the team to follow up with you and assist you further.


- Pradeep

Community Member

please i need help with my time tracker


Hi Omola,


I'm sorry to learn you're having difficulties installing the Upwork Desktop App. Please try the steps in this help article to troubleshoot your Time Tracker App. You may also report your issue by following the steps on 'How do I report a problem? So our team can assist you further. 


~ Arjay
Community Member

'm trying to download upwork time tracker


Community Member


I am too facing issue with upwork desktop app. I installed the latest version today. It starts but no window shown. 

Latest Articles
Top Upvoted Members