๐Ÿˆ Community
ยป Forums ยป Freelancers ยป Upwork Support link is not working
Page options
ranimanju
Community Member

Upwork Support link is not working

Hello Everyone, I am trying to contact upwork and whenever I click on GET HELP button nothing happens. Its not allowing me to create a ticket neither chat with support. Is there any other way to contact upwork support?

28 REPLIES 28
petra_r
Community Member


Manju R wrote:

Its not allowing me to create a ticket neither chat with support.


You don't have access to Chat because you're not top-rated, but should be able to create a ticket.

 

You can ask your question here as well.

How can i create a ticket?

Hi Manju,

 

You should be able to create a support ticket on this page. You can also let us know here what issues or questions you have and I'll make sure to escalate your concern/issue to the correct department.

 

Thank you.

~ Aleksandar
Upwork

I am having issues today too with the entire support system.   I can only get to the main support page.   If I click on ANY link on that page, it momentarily shows the page and the sends me back to the main support page.    Aleksandar D's link also sends me to the main page.   I cannot put in a support ticket because the page automatically goes immediately back to the main support page.    

 

I am also trying to complete the video verification.  I have been online for several hours now and it keeps saying it is timing out.    

 

I've tried both functions on two separate computers and am getting the same result.     

Hi Eddie,

 

We'll have one of our agents reach out to you via a support ticket to assist you with your verification process.

 

Thank you for reaching out to us. 

~ Bojan
Upwork
cpezu
Community Member

Hi my support link is not working it keep on redirecting me to the landing page.I wish to add a card which is getting refused to buy connects your help will be much appriatiated 

g_vasilevski
Retired Team Member
Retired Team Member

Hi Pezan,

 

Are you receiving any errors on your end? If yes please share the text of the error with me, thank you.

~ Goran
Upwork

No when I try to click on any link in https://support.upwork.com/ it takes me back to the dashboard. However, if I am logged out it works well.I need to contact support as I need help to buy connects using a card in my dad's name.
g_vasilevski
Retired Team Member
Retired Team Member

Hi Pezan,

 

I would like to confirm that our engineering team is aware of this problem and is working on resolving it as soon as possible.


Regarding your billing method, you can add only one of our accepted billing methods. If you`re receiving any errors when you`re adding your method, let me know here. Thank you.

~ Goran
Upwork
skynet-tech-ghy
Community Member

I have observed this weird behavior - Upwork support web pages redirect to support homepage.

This happens when I am logged in to my Upwork.

Since I am new on Upwork, I tend to click on various Upwork pages links from the Upwork Community, and every time it reloads the Upwork Support Homepage instead of the specific URL.

Doesn't happen, if I am logged out or using Private Browsing/Incognito Mode.

 

Hi Saquib,

 

One of our team members will reach out to you via ticket as soon as possible and assist you further with our Help Center. Thank you.

~ Goran
Upwork

All right. Thank you for the update. This issue is just annoying, hence reported for the benefit of the community.
Is it just me or affecting everyone?
I can replicate the issue again, if required.


Saquib A wrote:

Is it just me or affecting everyone?
I can replicate the issue again, if required.


It's been reported many, many times since yesterday. They know

bd30f2c0
Community Member

I will be happy to provide excruciating detail on all I tried if Support is interested.   And just for a quick recap, I tried with:

1) Windows 10 on a Lenovo laptop and Chome browser

2) Windows 10 Pro on Toshiba laptop with Chrome browser

3) The same two computers above with Edge browser

4) A Raspberry Pi (Model 4B with 4GB RAM) running Linux and Chromimum browser.

 

Only (4) worked.   Everything else did not.    Since (4) did not have a camera, I finally had to use my iPhone to open the Google Meet for the verification... 6 hours later.    

 

I will say that my sanity was only preserved because I found out I was not the only person having problems by going to the Community.    Thank you Community!

Hi again,

 

I just wanted to let those who are still having trouble with support page, I have found that it seems to be isolated to Google Chrome.   The issue of being sent back to the Support Main page regardless of what is selected does not happen with Microsoft Edge.    I just tried this again and found I could launch Edge and the log in through Google like I have done in the past.   I also was able to get it to work with Google Chromium, but I cannot recommend people use this on Windows computers due to the security risk.   But you may find other browsers besides Edge will work.

 

Also, when you do log in with Edge I noticed that verification screens or other pop-up screens get pushed behind the main browser screen.   So I had to slide my page out of the way to see my verification screen.     I was able to get all my tasks completed once i discovered the solution.    And again, it was the Community that helped me with this.

 

I was told that Support is working to fix the Google Chrome issue.

 

I hope this helps anyone still having the issue.

prabhath_tharaka
Community Member

Why Help and Support redirect me to home I can't request any help?

after redirection URL became like this

 "https://support.upwork.com/hc/en-us?code=b57ae7d61d07c8c5ac50b3183007f0ca"

and on console

"Access to XMLHttpRequest at 'https://www.upwork.com/api/v3/oauth2/token' from origin 'https://support.upwork.com' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource."

I have clear the browser cache but didn't work,

Please help me.

 

Hi Prabhath,

 

I`m sorry for the inconvenience this has caused you. I would like to confirm that our engineering team is working on resolving this as soon as possible.

Feel free to let me know here about how can I assist you further. Thank you.

~ Goran
Upwork

Hi Goran,

I have added my local bank account as a payment method on UpWork but the payment method has been deactivated because "the beneficiary name on your payment method does not match the name on your Upwork account" I have contacted Upwork Support they informed me that "the name mismatch will be reviewed by our team and would be available within 24-48 hours. "

I have to use my legal bank account name that provided by the local bank and

I have been waiting 4 days up to now. 

could you please help me with this issue?

Thank you so much for your reply.

Prabhath.

Hi Prabhath,

 

I`m sorry about the delay with this, your payment method is now approved. Thank you.

~ Goran
Upwork

Hi Goran

Thank you for your assistance, support, and prompt response in this matter is greatly appreciated.

Thanks again for your help,

Prabhath.

wgbader
Community Member

Hello,

 

I need help. The help site with so many useful links (https://support.upwork.com/hc/en-us?code=e54a860c62fc00102d27fdcbe5caa2f1) ejects me seconds after I display it. If I'm fast enough to click on one of the tutorial links, it still bounces me. Once in a great while it lets me watch videos, but not enough to matter. 

 

I tried saving it as a complete page with no better results: click on a link, then get bounced back to the website itself.

 

Is there another URL to use? Or am I making some kind of mistake?

 

Thanks

Hi Bill,

 

I'm sorry for the inconvenience this has caused. Please know, our engineering team is aware of the issue and working on solving it as soon as possible. Feel free to let us know what you need help with here and we'll be happy to assist.

 

Thanks!

~Andrea
Upwork

Hello, 

 

I am also experiencing the same issue. I cannot click on any links on the help page without it redirecting back to the intro screen for upwork support. Clicking "get help" does nothing and I have tried on every browser I have available with no help. I called into support but it is after hours. I cannot open a ticket or get any help. Is there any way to fix this? Who do I contact? 

Hi Yuliya,

 

Iโ€™ve shared your concern with the team. One of our team members will reach out and assist you directly via a support ticket. 

~ Joanne
Upwork

Thank you!

bd30f2c0
Community Member

I found that the issue you brought up occurs on the Google Chrome
browser. If you are on a WIndows machine, try using the Edge browser.
I notice it also works on Safari.
ebb39dd1
Community Member

I am also having the same issue.  I am using a Macbook and using Chrome Browser.  It's a circular issue, I keep going to https://support.upwork.com/, and any article/link I click on, keeps taking me back to the Support landing page.  It's an endless loop.

I'm answering my own issue as I just saw someone mentioning that this issue is related to Google Chrome browser.  I used Safari browser instead and now I am able to access the support articles.  Here's something to remember:  If you are finding yourself on an endless loop syndrome, it could be because you are using Google Chrome. You won't be sorry if you use Safari.

Latest Articles
Featured Topics
Learning Paths