Reply
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Upwork desktop app update won't download

Highlighted
Active Member
Olya D Member Since: Nov 6, 2019
1 of 3

Hi, I've had this issue for over a year now.

 

Whenever a new update comes up (which happens quite often), my desktop Upwork app offers me to download the update.

I click 'Update now' > 'installing update' appears > and after a few secs I see the message 'Update failed, please try again". No matter how many times I retry, it won't work. Mobile internet, Wi-Fi in at least 2 places - nothing helps. I even tried on different laptops - one old, another one brand-new. No-thing.

 

Last summer the support team sent me a lifehack, which is basically deleting the app from the system and downloading it again. And yes, it worked. But a few weeks later a new update came up and the issue followed.

 

The notification urging to update the app comes up constantly and, frankly, pisses me off Smiley Happy

 

Can someone fix it for me once and for all?

 

Thanks a bunch!

Highlighted
Moderator
Joanne Marie P Moderator Member Since: Nov 26, 2017
2 of 3

Hi Olya,

 

One of our team members will reach out and assist you directly via a support ticket. Thank you!


-Joanne
Untitled
Highlighted
Active Member
Olya D Member Since: Nov 6, 2019
3 of 3

Hi Joanne,

 

The support team representative did reply to me with the following instructions:

"In order to fix this issue, we would like to request you to uninstall the app totally and remove the Upwork folder manually by going to the links below:
Windows: %USERPROFILE%\AppData\Local\Upwork\Upwork\Logs
Mac: Navigate to Go > Go to Folder > Upwork > ~/Library/Application Support/Upwork/Upwork/Logs
Linux: ~/.Upwork/Upwork/Logs/

Once deleted, you can go ahead and install the latest version by following the link below:
Download Here/https://www.upwork.com/ab/downloads/"

 

But I followed this path before and it never helped to get rid of this bug.

Once a new update is released, the downloading won't work. And I should start it all over again :/

 

I used to think the problem was with my old laptop. But now I'm using a new model, another Windows version and the issue persists.

 

I opened this discussion to see if there are other Upworkers facing the same issue and, if yes, perhaps your tech team can look into it more carefully.

 

Thanks!!

TOP SOLUTION AUTHORS
TOP KUDOED MEMBERS