» Support » Known Issues and Workarounds » Issue with adding portfolio. Unable to click ...
Page options

Issue with adding portfolio. Unable to click on "Go to Preview".

Some users may experience issues while adding a portfolio to their profile. 


Screenshot of issue. 



I would like to let you know that our engineers are aware of this issue and they are working as fast as possible to resolve it. We will update this thread once we have more information. 


While this issue is being resolved we would like to provide a workaround. Could you please try and add an image or video link to the Project Solution section as shown in the screenshot below?


Once done, the "Go to Preview" button should no longer be greyed out. Feel free to let us know if you need further assistance. 


Edited to update information. 10/12/2023


We would like to let you know that this issue is now resolved. Our engineers also made improvements to the Portfolio section to make it more clear what fields are required. 


The changes that were implemented include:


  • Adding asterisks to required fields and a message on the file inputs to let freelancers know that those are required. Any required fields must be attended to in order for the preview button to work.
  • Also, when it comes to a "Case study" type of portfolio there are two fields that have to have at least one file uploaded or a video link needs to be provided.


Screenshots for reference.


Required fields.




"Case study" type.





We appreciate your patience. 

Community Member

I solved this issue, at least in my case. I found that when I input description content in the form by cutting and pasting it from my text doc, the form didn't recognise that there was content, which cased the issue. I had to start over by typing directly into the form. 


So, I solved this by typing directly into the form, rather than pasting text into the form. 


I'll also point out that after a year of seeing this same issue reported, the forum moderators and Upwork support repeatedly gave the same responses - try a different browser, clear your cache - which do not solve the problem. They get a big thumbs down. 

Community Member

hi. i too am having this problem. Ive already tried another browser and cleared cache and cookies.

Community Member

Hi, I'm also having this problem with my Safari browser. I've also tried to add the description by writing in manually but, the problem is still there.


Hi M N and Makka,


Thank you for reaching out and reporting this here in the Community. We apologize for the inconvenience of having this error. I've immediately converted your reports into a support ticket to give it the attention it deserves. Rest assured that one of our agents will contact you via a support ticket with further assistance. You may access your tickets for updates and coordinate with the team on this page.


Community Member

@pradeep H 


I am having the same issue. I agree with Tamara that it would be great to have a solution to this issue be made public.  





Hi Rudi,


Have you tried clearing your browser’s cookies or using a different browser? If the issue still persists, could you please share the following information so that we can forward it to our team to be investigated further?

  • Browser/s used
  • Browser version
  • Machine’s OS
  • Machine’s OS version
  • Screengrab of the issue
  • Additional details that may help us/the team investigate your concern better
Community Manager
Community Manager

Hi All,


Thank you for reaching out to us and bringing this to our attention. I would like to clarify that we are looking into your reports and will follow up with more information as soon as possible. 


Community Manager
Community Manager
Status changed to: Workaround
Community Member

having this issue currently. truly amazing how spotty this platform is given its size. 

Community Member

This issue isn't solved, I am having experiencing it right now. Extremely frustrating.