🐈 Community
» Forums » Freelancers » UpWork desktop app not finish loading
Page options
Community Member

Upwork desktop app issue when starting

Hi, im trying to start the desktop app but the app just stays loading, i tried uninstalling it, but i think there still some data to delete somewhere. tried open as admin and the same result.


some idea?


current version installed: v.5.4.71



EDIT: the app starts but nothing else happens just keep loading.

Community Member

Hi All,


We'd like to confirm that the issue has been resolved. To launch the App, you may need to  shut it down or "kill" it via system tools. On Mac it can be done via Activity Monitor utility. On Windows you will need to open Task Manager, find Upwork under Processes tab, select, click End task.

~ Valeria

View solution in original post


This doesn't work.


Could someone please assist urgently? I've been offline for 2 days

Hi Danielle,


I checked and it seems that you are already in correspondence with our team on your support ticketPlease allow more time for our team to review your case and respond accordingly to your ticket. You will be notified of their response.


~ Nikola

can you please share how did you sort that out

Community Member

I use UpWork desktop app for Windows 10. The app cannot be loaded tonight. I see an endless download screen.



I tried it:

But this does not help. Any advice - the client is waiting, I can't start work.

Community Member

Same here.

It worked for a while, now again I'm having the same issue.

I haven't been able to access the app for almost an entire day (Windows 10).  I have tried reinstalling. I have tried killing process via task manager. It appears in my open processes tray but nothing happens when I click on it. Frustrating to read that the problem is supposedly resolved.

Hi Morris, 


I'm sorry for the trouble you had. I have shared your concern with the team, and one of our agents will reach out and assist you directly via ticket. You may also want to check out the troubleshooting steps available here to help with desktop app issues.

~ Joanne



I am experiencing the same issue and have rebooted and reinstalled.

Upwork troubleshooting.PNG

Could support please assist me as soon as possible?

Hi Danielle,


Our team will reach out to you via ticket as well and will assist you further as soon as possible. Thank you.

~ Goran

Same issue face, can you help to fix issue.


Hi Jayesh,


I've shared your concern with the Time Tracker App with the team. One of our team members will reach out and assist you directly via a support ticket. 

~ Joanne

Hello I'm getting trouble for logging into my account via desktop app. It is stuck on the screen attached. Capture.PNG

Hi Muhammad,


One of our team members will reach out to you via ticket as soon as possible and assist you further with the desktop app. Thank you.

~ Goran

Thak You for your prompt response. But kindly fix it at earliest as I have to start working.

I am unable to use Upwork Desktop App. It just stuck on loading pop up screen and don't progress. Urgent help needed!

Hi Oun,


Could you please try to shut the Desktop App down or "kill" it via system tools before trying to open it again? On Mac, it can be done via the Activity Monitor utility. On Windows, you will need to open Task Manager, find Upwork under the Processes tab, select, click End task. If that doesn't help, please try reinstalling and let us know if the issue perists.



Latest Articles
Upcoming Events
Jun 22
Upwork Virtual Community Hour
Community Hour English
Featured Topics
Learning Paths