» Forums » Support » Re: Need urgent support - Screenshots not sup...
Page options
Community Member

Error: Screenshots are not supported on Wayland, please switch to Xorg.

What is this?! 


My Time Tracker got updated on Wednesday, and I haven't used it since then. Now that I started working again, I got this message. 

I don't know what Wayland (or Xorg) is, but this is unacceptable! Please fix it asap!


**Edited for Community Guidelines**

Community Member

If anyone else is experiencing this - here's a quick fix: https://linuxconfig.org/how-to-use-x-instead-of-wayland-on-ubuntu-22-04 

It worked for me 😄 

Thanks to Matt from CS!

View solution in original post

Community Member

If anyone else is experiencing this - here's a quick fix: https://linuxconfig.org/how-to-use-x-instead-of-wayland-on-ubuntu-22-04 

It worked for me 😄 

Thanks to Matt from CS!

Hi Valentina, 


Thank you for following up and sharing the solution with other users. I am glad to hear your issue is resolved. 

You will notice that edited your post title to better reflect the error message. This is so that other users who may experience the same issue can find the solution easier. 

~ Nikola
Community Member

You need to adapt your app, not your users to adapt their OS to your app! Should we expect a fix different than this change or deleting Upwork folder which does nothing at all?


While Wayland is the future of display servers on Linux, there are currently still some use cases where switching to X is necessary. The given step-by-step guide will help you switch from Wayland to X in Ubuntu 22.04. Remember to always carefully follow each step, and only make these changes if necessary and you understand the potential risks.

And here is one potential risk:

Important Caution

In some rare instances, if your X server is broken or not configured correctly, following these steps can lead to your system not booting. If your system fails to boot, you will need to reverse the changes made to the custom.conf file. You can accomplish this by selecting the recovery boot option from the GRUB menu, logging in as root, and commenting out or deleting the WaylandEnable=false line from the custom.conf file.


So you expect people to risk their systems or everyone to be familiar with recoveries? I have never seen an app that forces me to risk my OS.

Hi Emiliyan,


I understand your concern and would like to provide further clarification. I would like to let you know that Wayland is no longer supported so you may want to consider switching to a different system.
Additionally, I would like to clarify that the article shared on this post is not provided by Upwork. We shared it as a possible solution but we can't guarantee that it will work or how it will affect your system.


I will also share your feedback with our team for further review. 

~ Nikola

Why is it no longer supported while the whole linux community is moving forward to implement wayland more and more?


Community Member

Wayland was supported for a long time and worked like a charm (for Gnome environment at least). Please explain why did you decide to remove this support.

There are many desktop environments which support only Wayland.. And Wayland is the future of Linux desktops, without a bunch of design flaws specific to Xorg. Switching an existing system from Wayland back to Xorg means breaking a lot of stuff without any obvious benefits.

This solution didn't work for me. After changed the WaylandEnable=false and reboot the computer my desktop screen become crashed as shown in the attached image. Does anyone have other solution to fix it ?



Community Member

Lol, I had no idea someone could mark a post as a solution on my behalf. Anyway, this is a quick fix, and it works for me at the moment, but there are some real concerns, and I am not happy that I had to mess up with my OS to make the app work. 

I really hope the tech team will come up with a real solution soon.

Community Member

For those not willing to switch back to X.org with all its flaws, here is how you can get the Upwork Desktop working on Wayland again:


  1. download old version of the Upwork Desktop for Linux:
  2. remove Upwork Desktop using rpm or apt
  3. install the downloaded version using rpm or apt
  4. every time the app wants to update itself, accept all the prompts except the administrator priviledge prompt for actually updating the app (this is how it works on Fedora at least)

This way I'm able to use a standard linux distro with the default Wayland and have working screenshots as before.


Big thumbs down for Upwork devs working on the app. Removing Wayland support and forcing users to resort to the outdated X.org is ridiculous. It just demonstrates the partial monopoly Upwork has over the large share of freelance workers.


Community Member

I'm trying to use v5.8.31, as I already tested it in Wayland.  It was the version I was using until I had to install it again.

But now I can't find it.

Well , good try , but :)))) If you are running 5_8_0_24 it will ask to update to the newest version , otherwise it wont run. So we are dead locked ))))

Click on "update" until it asks you for root/sudo's password. On that prompt, just click on cancel, and it wil load without asking you to update.

Community Member

This is sad, with my work and workflow, I had to constantly switch (restart) to (xorg and wayland) just for other applications to work and finish my work. Hope Upwork devs resume support for Wayland and not force us to move to other OS. There are a lot of applications that works well and efficiently/faster on Linux and not on  i.e.: docker and etc.

I hope Upwork devs resume support for Wayland, xorg is getting outdated.

Community Member

It would be great if Upwork time tracker starts supporting the Wayland. A lot of the major linux distros are switching to Wayland, as well as we the linux enthusiasts want to use the wayland.

Community Member

Hello Upwork,

I'm quite concerned as I haven't been able to find a solution for the error I'm encountering on the Upwork community or through Google searches.

I've downloaded the latest version of Upwork from the official website and successfully installed it on my Ubuntu 23, the most recent version available. Despite being able to install, run, and activate the timer, I'm consistently encountering an error message that pertains to the issue mentioned in this post.


It's worth noting that I've tested Upwork on my Mac laptop, where it functions perfectly. However, due to certain reasons, I need to proceed with using it on my Ubuntu system.


At this point, I've taken the step of uninstalling the latest version of the Upwork time tracker and deleting the relevant files. Instead, I installed an older version (upwork_5.8.0.24_amd64.deb), but now I'm facing login errors through the browser. When I attempt to log in via the browser from the Upwork timer interface, it redirects me to the login page, where I click the login button. This action then prompts a popup to continue the login process in the Upwork desktop app. After clicking "OK," however, I do not get redirected back to the Upwork desktop app as expected.


I'm at a loss and unable to successfully run the Upwork timer on my Ubuntu system despite these efforts.


Please refrain from suggesting a change of operating system. Provide an authentic solution, considering that I'm currently using the latest version of Ubuntu.

Sajid U.

work SMART not HARD
Community Member

Hello freelancers am having the same issue in my ubuntu latest version with the latest version of the upwork time tracker ,switching to X.org cause gnome issues which affects my productivity i hope UpWork will find solution for us because i can't switch to other os because the project depends on ubuntu os . anyone has a solution

Community Member

Same issue, upwork devops must take notice of it.

Community Member

Wow, six month has passed and it is not fixed yet?

Community Member

It's unbelievable that the latest version of the tracker is so riddled with bugs and regressions like this one. Electron already supports wayland screenshots. The previous version worked! You not only launched a terrible upgrade but also decided to do nothing since december.


Fedora 40 has already removed Xorg for Plasma and the next version will also remove it for Gnome. Ubuntu has set Wayland as the default for at least a couple of years. It won't be too long before the majority of Linux users are on Wayland.


As I said, Electron already supports this. You probably only need to revert a single commit to make it work for everyone again.


What happened? Did you change the tracker app team leader? The tracker is the only differentiator your platform has and you are letting it rot. The only solution for your users, who depend on this to make a living, is to downgrade and exploit a confirmation bug to avoid the forced upgrade. Please hire professionals to work on the tracker

Latest Articles
Featured Topics
Learning Paths